adel25159
?>

Напишите программу нахождения среднего арифметического трехзначных чисел, оканчивающихся цифрой 7

Информатика

Ответы

oloinics
Program z14;  Var i, j:integer; sr: real;Begin  for i:=100 to 999 do    if (i mod 10 = 7)       then       begin        sr:= sr + i;        j:= j + 1;      end;    sr:= sr / j;  writeln('Среднее значение = ', sr);End.
druzjkinaas22

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?

repeat <оператор1, …>until <условие>

while <условие>do <оператор>

for <параметр>:= <начальное значение>to<конечное значение> do<оператор>

2. Используется оператор for i:= -10 to 10 do…

После завершения выполнения тела цикла i = 10

3. Цикл в фрагменте программы

p:=1;

repeat

p:=p*0.1

until p>0.1;

будет исполнен:

1 раз

2 раза

бесконечное число раз

0 раз

3 раза

4. Цикл в фрагменте программы

a:=1;

b:=1;

while a+b<8 do

begin

a:=a+1; b:=b+2

end;

выполнится:

0 раз

3 раза

2 раза

1 раз

бесконечное число раз

5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?

НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.

while <условие> do <оператор>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

repeat <оператор1, …> until <условие>

6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?

repeat <оператор1, …> until <условие>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

while <условие> do <оператор>

7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a:=1; b:=1;

while a<=32 do a:=a*2; b:=b*a;  //Обратите внимание! Нет begin end.

write (b)

32

256

64

128

8. Используется оператор for i:= -5 to 9 do…

При первом выполнении тела цикла i = -5

9. Чему равно значение переменной s после выполнения следующего фрагмента программы

Фрагмента программы нет! Задание решить нельзя!

ski89439

1 задача:

import math

a=int(input())

b=int(input())

if(math.fabs(a+b)>20):

   print(math.pow(a,2))

else:

   b=math.fabs(b)

   print(math.sqrt(b))

2 задача:

a=int(input())

if a == 5:

   print("Отлично")

elif a == 4:

   print("Хорошо")

elif a == 3:

   print("Удовлетворительно")

elif a == 2:

   print("Плохо")

elif a == 1:

   print("Отвратительно")

else:

   print("Это не оценка")

3 задача:

x=int(input())

y=int(input())

a=int(input())

b=int(input())

a7 = a%x

b7 = b%y

if(a7>b7):

   print("7A")

else:

   print("7Б")

4 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<100:

       r=13*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   elif a>100:

       r=math.pow(a,3)-100

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=30-(a/(a-5))

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

5 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<4:

       r=3*a-7

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=5*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу нахождения среднего арифметического трехзначных чисел, оканчивающихся цифрой 7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

turaev-1098
gilmore886173
apetit3502
info292
BogdanR106203
Vasilevskii
Svatela37
igortychinin
club-pushkin
irinalav2705745
Shitikov-M.A.1307
Александрович784
musaevartur
Vladimirovich Aleksandr1889
D.Yu. Polina1703
▲