Georgievna
?>

Синформатикой напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел. sample input 1: 1234 sample output 1: 12 34 sample input 2: 1200 sample output 2: 12 00 напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд. sample input 1: 12345 sample output 1: 54321 sample input 2: 12000 sample output 2: 21

Информатика

Ответы

andrey
#include <iostream>using namespace std;int main() {  int a, b, c, d;  cin >> a;  b = a/100;  c = a%100;  cout << b << " " << c;  return 0;}
но есть проблема, переменные типа int сокращает 00 до 0
и на выводе получается не 12 00, а 12 0
ooost-2022
Если вынуть 94 конфет, то будут конфеты всех 3 видов.Пусть у нас по n конфет каждого вида.Тогда может так получиться, что мы вынем 2n конфет, и они будут только 2 видов. И только, вынув (2n+1)-ю конфету, мы получим все три.2n+1 = 942n = 93.Значит, конфет одного и другого вида по [93/2] = 46,а конфет третьего вида 47.Пусть ирисок и леденцов по 46, а шоколадных 47.Вынув 46 ирисок и 46 леденцов (92 конфет), мы получим 2 вида.Вынув 46 ирисок и 47 шоколадных (93), мы получим 2 вида.Вынув 46 леденцов и 47 шоколадных (93), мы получим 2 вида.И только вынув 94-ую (в 1 случае 93 и 94), мы получим 3 вида.ответ: всего конфет было 46 + 46 + 47 = 139.
Vladimirovna Dmitrieva
Если, например, Х = 5 сек, то за 5 сек Флэш выпустит 2 молнии, а за 10 сек - 3.
То есть количество молний A = int(Y : X) + 1, где
Y = N*60 + M - количество отведенного времени в секундах.
Вся суть программы:
X = Input (input.txt, X); // Принимаем секунды из файла, пишем в переменную X
N = Input (input.txt, N); // Принимаем минуты из файла, пишем в переменную N
M = Input (input.txt, M); // Принимаем секунды из файла, пишем в переменную M
Y = N*60 + M; // Вычисляем отведенное время в секундах
A = int(Y : X) + 1; // Вычисляем количество молний
Output (A, output.txt); // Выводим его в файл.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел. sample input 1: 1234 sample output 1: 12 34 sample input 2: 1200 sample output 2: 12 00 напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд. sample input 1: 12345 sample output 1: 54321 sample input 2: 12000 sample output 2: 21
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Долбоебков_Алексей27
ilds88
yurazharov
ЕкатеринаРустам
Viktoriya405
Yelena_Irina826
alexander4590
Зинина-Олесия
shumeikoElena362
vitbond12
Paikina Natalya30
Ryazanova1575
vasavto1
aleksey270593
Давид-Ольга