elmira01048775
?>

Составьте программу, которая задаёт : "в каком году был основан город минск ( например , в 1067 г., в 993 г., либо в 1147 " в случае верного ответа программа должна сообщить "верно" , в противном случае - "вы ошиблись".

Информатика

Ответы

annademidova-74

var

a: integer;


begin

writeln('В каком году был основан город Минск?');

writeln('1) 1067');

writeln('2) 993');

writeln('3) 1147');

readln(a);

if a = 1 then writeln('Верно')

else writeln('Вы ошиблись');

end.

denbelousov963
Uses graphABC;
begin
setwindowsize(600,500);
setbrushcolor(clMedGray);
Ellipse(320,30,490,400);
Ellipse(120,30,300,400);
setbrushcolor(clCream);
Ellipse(335,40,480,380);
Ellipse(140,40,280,380);
setbrushcolor(clMedGray);
Ellipse(100,430,500,130);
setbrushcolor(clNavy);
Ellipse(250,240,200,310);
Ellipse(350,240,400,310);
setbrushcolor(clwhite);
Ellipse(240,270,220,300);
Ellipse(360,270,380,300);

setbrushcolor(clblack);
Ellipse(270,330,330,370);
line(300,370,300,400);
Arc(300,280,120,220,-40);

line(50,350,200,350);
line(30,340,190,340);
line(10,330,180,330);

line(410,330,570,330);
line(400,340,560,340);
line(390,350,550,350);

line(240,230,220,150);
line(230,230,180,80);
line(220,230,180,150);

line(360,230,380,150);
line(370,230,430,80);
line(380,230,430,150);

end.
Эта
kamimoza
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=SeqRandom(ReadInteger('n='),-50,50).Select(n->double(n/10)).ToArray;
  a.ForEach(x->Write(x:0:1,' ')); Writeln;
  Writeln('Сумма отрицательных: ',a.Where(x->x<0).Sum);
  var p:=a.IndexMin;
  var q:=a.IndexMax;
  if p>q then Swap(p,q);
  Writeln('Произведение на интервале: ',
      a[p+1:q].Aggregate(1.0,(x,y)->x*y));
  Writeln('Сортировка:');
  a.Sort; a.ForEach(x->Write(x:0:1,' ')); Writeln;
end.

Пример
n= 13
1.7 -0.8 -1.3 -1.4 5.0 -3.1 -0.7 -2.7 2.6 -4.9 4.0 -2.0 -2.0
Сумма отрицательных: -18.9
Произведение на интервале: -15.2334
Сортировка:
-4.9 -3.1 -2.7 -2.0 -2.0 -1.4 -1.3 -0.8 -0.7 1.7 2.6 4.0 5.0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая задаёт : "в каком году был основан город минск ( например , в 1067 г., в 993 г., либо в 1147 " в случае верного ответа программа должна сообщить "верно" , в противном случае - "вы ошиблись".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mantseva
solonataly5
printlublino
Староческуль-Станиславовна
larisau41
amayonova
Kondratchik Vladimir
orbbsvsupply
lenalevmax7937
Anait_Natalya451
petr2077
mshelen732
Коробкова1437
mashere59
krasnova1977