?>
Нужно написать программу в ms visual c#, .. услуги телефонной сети оплачиваются по следующему правилу: за разговоры до а минут в месяц – в рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета с рублей за минуту. требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.
Ответы
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace zn
{
class Program
{
public static void Main(string[] args)
{
Console.Write("Введите кол-во минут по тарифу: ");
int a = Convert.ToInt32(Console.ReadLine());
Console.Write("Введите цену за минуту по тарифу: ");
int b = Convert.ToInt32(Console.ReadLine());
Console.Write("Введите цену за минуту сверх тарифа: ");
int c = Convert.ToInt32(Console.ReadLine());
Console.Write("Введите время пользования услугами связи за месяц в минутах: ");
int d = Convert.ToInt32(Console.ReadLine());
int res = a > d ? a * b : a * b + (d - a) * c;
Console.WriteLine("Плата за пользование: " + res);
Console.ReadKey();
}
}
}