Поделитесь своими знаниями, ответьте на вопрос:
Паскаль. почему это решение не верно? студент валера являет собой классический пример лентяя. на занятия он практически не ходит, и только в конце семестра появляется в университете и сдает ”хвосты”. его заветная мечта: найти такой день, когда можно будет сдать сразу все долги. у него есть расписание работы преподавателей, из которого точно известно, с какого и по какой день месяца каждый преподаватель ежедневно будет доступен. валере написать программу, которая по расписанию будет определять, сможет ли валера сдать все долги за один день или нет. var i, max, min, n: integer; a, b: array[1..100]of integer; begin read(n); max: =0; min: =32; for i: =1 to n do begin read(a[i], b[i]); if a[i]> max then max: =a[i]; if b[i] end; if min> max then writeln('yes') else writeln('no'); end.
a,b:array[1..100]of integer;
i,max,min,n:integer;
begin
readln(n);
max:=0; min:=32;
for i:=1 to n do
begin
readln(a[i],b[i]);
if a[i]>max then max:=a[i];
if b[i]<min then min:=b[i];
end;
if min>=max then
writeln('YES')
else writeln('NO');
end.
Пример:
3
1 5
3 10
4 14
YES