ответ:http://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ru
Объяснение:http://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ruhttp://planetoflife.ru
{PascalABC}
Program Begenjov1997;
const
n = 30; {Количество элементов массива}
m = 10000; {Максимально возможное значение элемента}
var
a:array[1..n] of integer;
i, sum: integer;
s:string;
begin
s:=' -=Alphaeus=- ';
for i:=1 to 22 do begin write(s[i]); sleep(60) end;
{заполняем массив случайными числами}
writeln; randomize;
for i:=1 to n do
begin
a[i]:=random(m+1);
end;
{Ищем максимальную сумму двух соседних элементов}
sum:=a[1]+a[2];
for i:=2 to n-1 do
if (a[i]+a[i+1]>sum) then sum:=a[i]+a[i+1];
{Заменяем элементы, кратные 3, наденной суммой}
for i:=1 to n do
if (a[i] mod 3 = 0) then a[i]:=sum;
{Вывод}
writeln('Массив А в обратном порядке:');
for i:=0 to n-1 do writeln(a[n-i],' ');
writeln();
writeln('Максимальная сумма двух соседних элементов равна ',sum);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу в паскале pascal авс для самостоятельного решения 1) известно количество символов в каждой строке, количество строк на странице. написать про-грамму, вычисляющую число символов на странице. 2) составить программу, запрашивающую при операторов ввода-вывода: название куп-ленного товара, количество и цену за единицу. после вычислений и очистки экрана следующие сообщения: название товара и его общая стоимость. 3) известно оклад сотрудника, количество отработанных дней и число рабочих дней в месяце. составить программу нахождения заработной платы сотрудника, с учетом вычетов подоходного налога (13%) и пенсионного налога (1%
cl,lp:integer;
begin
Write('Количество символов в строке- '); Read(cl);
Write('Количество строк на странице- '); Read(lp);
Writeln('Количество символов на странице: ',cl*lp)
end.
Пример
Количество символов в строке- 68
Количество строк на странице- 45
Количество символов на странице: 3060
uses Crt;
var
nt:string; { наименование товара }
kt:real; { количество товара }
ct:real; { цена товара за единицу }
begin
Write('Наименование товара- '); Readln(nt);
Write('Количество товара- '); Read(kt);
Write('Цена за единицу товара- '); Read(ct);
ClrScr;
Writeln(nt,' - ',ct*kt:0:2)
end.
Результаты работы программы даны во вложениях
const
podn=0.13; { подоходный налог }
pensf=0.01; { в Пенсионный фонд }
var
os:real; { оклад сотрудника }
nd:integer; { количество отработанных дней }
nr:integer; { количество рабочих дней в месяце }
nach:real; { начислено }
sp:real; { сумма подоходного налога }
spf:real; { сумма отчислений в ПФ }
nzp:real; { итого начислений на зарплату }
svyd:real; { сумма к выдаче }
begin
Write('Оклад, руб- '); Read(os);
Write('Отработано дней- '); Read(nd);
Write('Рабочих дней- '); Read(nr);
nach:=os*nd/nr; { может получиться нецелое число }
{ округлим до сотых долей }
nach:=Round(nach*100)/100;
sp:=nach*podn; sp:=Round(sp*100)/100;
spf:=nach*pensf; spf:=Round(spf*100)/100;
nzp:=sp+spf;
svyd:=nach-nzp;
Writeln('Начислено, руб: ',nach:0:2);
Writeln('Подоходный налог, руб: ',sp:0:2);
Writeln('В Пенсионный фонд, руб: ',spf:0:2);
Writeln('Итого налогов, руб: ',nzp:0:2);
Writeln('К выдаче, руб: ',svyd:0:2)
end.
Пример
Оклад, руб- 46420
Отработано дней- 19
Рабочих дней- 22
Начислено, руб: 40090.00
Подоходный налог, руб: 5211.70
В Пенсионный фонд, руб: 400.90
Итого налогов, руб: 5612.60
К выдаче, руб: 34477.40