Маргарита595
?>

Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные

Информатика

Ответы

anytkaakk
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите двухзначное натуральное число:');
  if (n div 10).IsEven and (n mod 10).IsEven then Writeln('Да')
  else Writeln('Нет')
end.

Пример
Введите двухзначное натуральное число: 28
Да
vardartem876
Program oddn;
var
a,b,c: integer;

begin
readln(c);
a:=c div 10;
b:=c - a*10;
if (a and 1=0) and (b and 1=0) then
writeln('все цифры четные')
else
writeln('есть нечетные цифры');

end.
Lyubov214

program same;

var

 number: string;

begin

 read(number);

 if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then

   writeln('Да')

 else

   writeln('Нет');

end.

Объяснение:

program same;  // Название программы

var

 number: string;  // Создание строковой переменной number

begin  // Начало программы

 read(number);  // Считываем значение переменной number с клавиатуры

 if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then  // Если ((1 цифра = 2 цифре) ИЛИ (2 цифра = 3 цифре) ИЛИ (1 цифра = 3 цифре))

   writeln('Да')  // Выводим Да

 else  // Иначе

   writeln('Нет');  // Выводим Нет

end. // Конец программы

Сурат1199

program restoran;

var

 first, second, third, fourth: integer;

 first_tip, second_tip, third_tip, fourth_tip, amount: real;

begin

 amount := 0;

 read(first, second, third, fourth);

 first_tip := first / 100 * 15;

 second_tip := second / 100 * 15;

 third_tip := third / 100 * 15;

 fourth_tip := fourth / 100 * 15;

 amount := first_tip + second_tip + third_tip + fourth_tip;

 write(amount);

end.

Объяснение:

program restoran;  // Название программы

var

 first, second, third, fourth: integer;  // Создание целочисленных переменных, отвечающих за счёт, на который пообедали гости

 first_tip, second_tip, third_tip, fourth_tip, amount: real;  // Создание вещественных (с плавающей точкой) переменных, отвечающих за размер чаевых и сумму чаевых соответственно

begin  // Начало программы

 amount := 0;  // Сумма = 0

 read(first, second, third, fourth);  // Считываем значения счетов каждого гостя с клавиатуры

 first_tip := first / 100 * 15;  // Чаевые с первого счета

 second_tip := second / 100 * 15;  // Чаевые со второго счета

 third_tip := third / 100 * 15;  // Чаевые с третьего счета

 fourth_tip := fourth / 100 * 15;  // Чаевые с четвертого счета

 amount := first_tip + second_tip + third_tip + fourth_tip;  // Сумма чаевых

 write(amount);  // Вывод суммы

end. // Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задано двухзначное число. составить программу, которая отвечает на вопрос, правда ли, что все его цифры чётные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sancity997124
ГармаеваЕкатерина1637
Михеев557
Chistova-Dmitrii1162
Aleksandrovna Kolesnik1764
Aleksandrovich-Yurevna1421
grafffmc
Египтян2004
lescha-77766
ekb676
Gennadevna_Baidalina131
dearmaria
Pastel-sova
Viktorovich
potapin