zamkova836
?>

Составьте программу, которая определяет, является ли треугольник с заданными длинами сторон равносторонним, равнобедренным или разносторонним, и выводит на экран соответствующее сообщение: "равносторонний", "равнобедренный" либо "разносторонний". предполагается, что треугольник с заданными сторонами существует.

Информатика

Ответы

mnogomams47
#include <iostream>using namespace std;int main(){    int a,b,c;    cin>>a>>b>>c;    if(a==b==c)cout<<"Равносторонний";else if(a==b&&b==c)cout<<"Равнобедренный";else cout<<"Разносторонний";
}
Грачева мураховская

1) сначала переведём

1*2^5+0*2^4+1*2^3+1*2^2+0*2^1+1*2^0 = 45 ( в десятой СС)  // ^это степень , тобишь разряд умножаем на 2 в степени разряда

1*2^5+1*2^4+0*2^3+0*2^2+1*2^1+0*2^0=50( в десятичной СС)

2) принадлежат интервалу = 45+46+47+48+49+50=285

3) переведём в двоичную СС

285/2 = 142, остаток: 1

142/2 = 71, остаток: 0

71/2 = 35, остаток: 1

35/2 = 17, остаток: 1

17/2 = 8, остаток: 1

8/2 = 4, остаток: 0

4/2 = 2, остаток: 0

2/2 = 1, остаток: 0

1/2 = 0, остаток: 1

285 = 1000111012

ответ: а)45-50  б) 1000111012

ikavto6
//Pascal ABC.NET Версия 2.2 Сборка 790
var s,d:string;
n,i,j:integer;
begin;
readln(n);
readln(d);
i:=1;
for j:=1 to n-1 do
i*=10;
j:=i;
while i*10<>j do
begin;
inc(j);
s:=inttostr(j);
if pos(d,s)=0 then write(s:5);
end;
end.

Пример ввода:
2
1
Пример вывода:
20   22   23   24   25   26   27   28   29   30   32   33   34   35   36   37   38   39   40   42   43   44   45   46   47   48   49   50   52   53   54   55   56   57   58   59   60   62   63   64   65   66   67   68   69   70   72   73   74   75   76   77   78   79   80   82   83   84   85   86   87   88   89   90   92   93   94   95   96   97   98   99

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая определяет, является ли треугольник с заданными длинами сторон равносторонним, равнобедренным или разносторонним, и выводит на экран соответствующее сообщение: "равносторонний", "равнобедренный" либо "разносторонний". предполагается, что треугольник с заданными сторонами существует.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yelena1458
ЕВ1873
rodin4010
spec-nt
mez-omts-d5
Кузнецов
ЕленаГерасимова
решить задание по информатике ​
stsnab
palchiknr
tobolenecivanov1675
vdm4275
gusrva3001
bei07
valentinakarma2800
grebish2002