Графический интерфейс (Graphical User Interface или GUI) создан для более удобного взаимодействия с пользователем (в отличии от просто командно-текстового взаимодействия или консоли)
Надпись, иконка - элементы для вывода информации текстовой и графической соответственноКнопка - базовый функциональный элемент для запуска определенной команды. Может содержать иконки и надписиТекстовое поле - одно/много-строчное, для вывода и ввода текстовой информации. Пункт меню - вариация кнопкиМеню - обычно древовидное объединение нескольких пунктов менюОбласти для вывода изображений и видеоКурсор мыши - элемент для удобного взаимодействия со всем вышеперечисленнымНе совсем точно, но более менее понятно. Так или иначе из комбинации этих элементов и состоят все графические интерфейсы
Поделитесь своими знаниями, ответьте на вопрос:
1. напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры 2. напишите программу, которая запрашивает два целых числа x и y, после чего вычисляет и выводит значение x в степени y. 3. найти среднее арифметическое всех целых чисел от 1 до 1000. 4. найти произведение всех целых чисел от a до 20 (значение a вводится с клавиатуры: 1 < =a < = 20). 5. написать программу, которая выводит на экран таблицу умножения на k, где k – номер варианта. например, для 7-го варианта: 7 x 2 = 14 7 x 3 = 21
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
long sum = 0;
int a;
cout << "Введите a" << endl;
cin >> a;
if (a > 500)
{
cout << "а > 500" << endl;
}
else
{
sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
cout << sum;
}
}
2.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
double average = (1 + 1000) / 2.;
cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;
}
3
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, b = 0;
cout << "Введите границы диапазона" << endl;
cin >> a >> b;
cout << "Все числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
cout << i << endl;
}
}
else
{
for (int i = b; i < a; i++)
{
cout << i << endl;
}
}
cout << "Чётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 == 0)
{
cout << i << endl;
}
}
}
cout << "Нечётные числа:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 2 != 0)
{
cout << i << endl;
}
}
}
cout << "Числа, кратные 7:" << endl;
if (a <= b)
{
for (int i = a; i <= b; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
else
{
for (int i = b; i < a; i++)
{
if (i % 7 == 0)
{
cout << i << endl;
}
}
}
}
4.
#include <iostream>
using namespace std;
void main()
{
//задаём русский язык для консоли
setlocale(LC_ALL, "Russian");
int a = 0, sum = 0;
cout << "Введите числа" << endl;
while (true)
{
cin >> a;
if (a == 0)
{
break;
}
sum += a;
}
cout << "Сумма =" << sum << endl;
}