Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
writeln ('y=',y)
end.
Объяснение:
Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
writeln ('y=',y)
end.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
for ( int i = 0; i < sizeOfFirstMass; ++i ) {
for ( int j = 0; j < sizeOfSecondMass; ++j ) {
if (a[ i ] == b[ j ])
cout << a [ i ] << " ";
}
}
но элементы могут повторяться, так как тут нет контроля над уже найденными совпадениями