Хромов1501
?>

Написать программу в pascal abc с оператором for. а то сам незнаю! написать программу, которая выводит на экран таблицу квадратных целых 10-ти положительных чисел. что-то вроде: program pin; var i, y: integer; begin writeln(''); writeln(''); for i: =1 to 10 do; begin end; end. можно и это но закончить, не получается у меня.

Информатика

Ответы

Eduardovich
Program pin;
var i:integer;
begin
for i := 1 to 10 do  writeln(i,'*',i ,' - ',i*i); end.

ну как-то так,если я правильно задание поняла (:
pastore
//Блок-схема во вложении
//Pascal ABC.NET 3.1 сборка 1219

uses
 system;

Var
 d1,d2:datetime;
 a:integer;
begin
writeln('1 дата:');
write('День:');readln(a);d1:=d1.AddDays(a);
write('Месяц:');readln(a);d1:=d1.AddMonths(a);
write('Год:');readln(a);d1:=d1.AddYears(a);
writeln('2 дата:');
write('День:');readln(a);d2:=d2.AddDays(a);
write('Месяц:');readln(a);d2:=d2.AddMonths(a);
write('Год:');readln(a);d2:=d2.AddYears(a);
writeln('Res:',abs((d2-d1).Days));
end.

Пример ввода:
1 дата:
День:1
Месяц:1
Год:1998
2 дата:
День:2
Месяц:1
Год:1999
Пример вывода:
Res:366
Составьте алгоритм определения числа дней между двумя датами и нарисуйте блок-схему. , кто разбирает
Alyona1692
1) 64*32/8/1024 = 0,25 кб; 1 / 0,25 = 4 бит пиксель; 2^4 = 16 цветов.
2) 50*80*(ln(16)/ln(2)) = 16000 бит; 16000 / 8 = 2000 байт.
3) 64*64*(ln(256)/ln(2)) = 32768 бит / 8 / 1024 = 4 кбайт минимум.
4) 2048*1536*3 байт пиксель = 9437184 байт / 8 / 1024 = 1152 кбайт.
5) (ln(256)/ln(2)) / (ln(2)/ln(2)) =8 раз меньше стал; (текущий уменьшенный вес файла + 70 байт) * 8 =~ 560 байт если весил 1 байт.
6) (ln(64)/ln(2)) / (ln(8)/ln(2)) = 2 раза.
7) (ln(1024)/ln(2)) / (ln(32)/ln(2)) = 2 раза.
8) 32*64/8 = 256; 512 байт / 256 = 2 бит пикс; 2^2 = 4 цветов.
9) 128*128/8/1024 = 2; 4 кб / 2 = 2 бит пикс; 2^2 = 4 цветов.
10) 1024*768*16 бит пикс = 12582912 бит / 8 / 1024 / 1024 = 1,5 мбайт.
11) 1024*512/8/1024 = 64; 256 кб / 64 = 4 бит пикс; 2^4 = 16 цветов.
12) 32*128*(ln(64)/ln(2)) бит = 24576 бит / 8 / 1024 = 3 кбайта.
13) 2^24 = 16 777 216 цветов; 1240*1024*(ln(16777216)/ln(2)) бит пикс = 30474240 бит / 8 / 1024  = 3720 кбайт для одной страницы требуется.
 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal abc с оператором for. а то сам незнаю! написать программу, которая выводит на экран таблицу квадратных целых 10-ти положительных чисел. что-то вроде: program pin; var i, y: integer; begin writeln(''); writeln(''); for i: =1 to 10 do; begin end; end. можно и это но закончить, не получается у меня.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergeevich-Drugov1513
ЧумичеваГеннадьевна1827
dariamay1996
peresvetoff100015
perovd8111
Zebra198383
Сергеевич1396
Васильев1028
Yelena-Svetlana
rsksnb
seleznev1980
nordwokintos4
Поликарпова-Мазурова
goryavinan
olechka197835
▲