makitra08
?>

С++ ! один из методов криптографии заключается в измерении частоты появляения буквы в тексте. необходимо написать программу, вычисляющую какую часть текста составляет указанная буква. т.е. отношения количества встречания одной буквы к количеству букв в тексте.

Информатика

Ответы

ТигранКалмыкова
// на вход в командной строке нужно подать название файла с текстом, в стандартном потоке указанный символ
#include <cstdio>

int
main(int argc, char **argv)
{
    char g_ch = getchar();
    FILE *fin = fopen(argv[1], "rt");
    int count = 0;
    int count_all = 0;
    char ch = 0;
    while ((ch = fgetc(fin)) != EOF) {
        if (ch == g_ch) {
            count++;
        }
        count_all++;
    }
    printf("%f\n", 1. * count / count_all);
    return fclose(fin);
}
Merkuloff78
#include <iostream>
#include <map>
using namespace std;
 
int main()
{
    string text = { "hello my name is paperman" }; // наш текст
    string word = { "" }; // слово для сравнения
    cin >> word; // просим ввести сравниваемую букву
    map<char, unsigned> key_map;
    for(auto i: text) {
        if (word.find(tolower(i)) != string::npos) {
            ++key_map[tolower(i)] ;
        }
    }
    for(auto &pair : key_map) {
        cout << "char: " << pair.first << " | count: " << pair.second << endl ;
    }
    return 0;
}
kristinagaspa62

Программа:

алг

нач

   цел х

   лит пол

   вывод 'Введите возраст: '

   ввод х

   вывод 'Введите пол (одной буквой): '

   ввод пол

   выбор

       при пол = 'м':

           выбор

               при х>=2 и х<4 : вывод '1000 калорий'

               при х>=4 и х<9 : вывод '1500 калорий'

               при х>=9 и х<14 : вывод '2000 калорий'

               при х>=14 и х<19 : вывод '2600 калорий'

               при х>=19 и х<31 : вывод '2700 калорий'

               при х>=31 и х<51 : вывод '2500 калорий'

               при х>=51 и х<100 : вывод '2300 калорий'

           иначе

               вывод 'Ошибка при вводе возраста'

           все

       при пол = 'ж':

           выбор

               при х>=2 и х<4 : вывод '1000 калорий'

               при х>=4 и х<9 : вывод '1500 калорий'

               при х>=9 и х<14 : вывод '1800 калорий'

               при х>=14 и х<19 : вывод '2000 калорий'

               при х>=19 и х<31 : вывод '2100 калорий'

               при х>=31 и х<51 : вывод '2000 калорий'

               при х>=51 и х<100 : вывод '1600 калорий'

           иначе

               вывод 'Ошибка при вводе возраста'

       все

   иначе

       вывод 'Ошибка при вводе пола'

   все

кон

Результат выполнения:


перевести программу из Паскаля в Кумир. program food ; var x:integer; y:char; begin writeln('введит
fialkaflowers77

1)1. Нажмите Кнопку «Office».

2. В появившемся меню нажмите кнопку Параметры Excel.

3. В открывшемся диалоговом окне щелкните кнопкой мыши на строке Формулы в списке, расположенном в левой части окна. Содержимое диалогового окна изменится.

4. Установите флажок Стиль ссылок R1C1, после чего нажмите кнопку ОК, чтобы применить изменения.

4)Зайти в режим правки

1.Дважды щелкните ячейку с данными, которые нужно изменить. ...

2.Щелкните ячейку с данными, которые вы хотите изменить, а затем щелкните в любом месте в области формул. ...

3.Щелкните ячейку с данными, которые вы хотите изменить, и нажмите F2.

6)На листе, содержащем столбцы чисел, щелкните ячейку, в которой должны выводиться результаты формулы.

Введите знак равенства (=).

Щелкните первую ячейку, которую требуется включить в вычисление.

Пример использования ссылки на ячейку в формуле

Введите оператор. Оператор представляет математическую операцию, выполняемую формулой. Например, оператор * (звездочка) перемножает числа. В этом примере используйте оператор / (косая черта), чтобы разделить числа. На этом этапе формула должна выглядеть так:

Пример использования оператора в формуле

Щелкните следующую ячейку, которую нужно включить в вычисление. Теперь формула должна выглядеть так:

Пример использования двух ссылок на ячейки в формуле

Нажмите клавишу RETURN.

В ячейке отобразится результат вычисления.

Пример использования ссылок на ячейки в формуле, показывающей вычисленный результат

6)

Выберите ячейку на листе.

Введите числа или текст, которые нужно ввести, а затем нажмите ввод или TAB.

Чтобы ввести данные в новой строке ячейки, введите разрыв строки, нажав ALT+ВВОД.

7) Введите формулу на чистый лист (чтобы можно было проверить как работает данный пример). Выберите инструмент: «Формулы»-«Параметры вычислений»-«Автоматически». Убедитесь, что теперь после ввода данных в ячейку (например, число 7 вместо 1 , формула не пересчитывает результат автоматически. Пока пользователь не нажмет клавишу F9 (или SFIFT+F9)

8)Перемещение ячеек путем перетаскивания

Выделите ячейки или диапазон ячеек, которые требуется переместить или скопировать.

Наведите указатель мыши на границу выделенной области.

Когда указатель примет вид указателя перемещения Указатель перемещения , перетащите ячейку или диапазон ячеек в другое место.

Перемещение ячеек с команд "Вырезать" и "Вставить"

Выделите ячейку или диапазон ячеек.

На ленте > вырезание Вырезать нажмите CTRL+X

8)Десятичный разделитель — знак, используемый для разделения целой и дробной частей вещественного числа в форме десятичной дроби в системе десятичного счисления. ...

В англоязычных странах в качестве десятичного разделителя используется точка . , в большинстве остальных — запятая

10)Введите в ячейку =СУММ, а затем открываю скобки (.

Чтобы ввести первый диапазон формул, который называется аргументом (частью данных, которую нужно выполнить), введите A2:A4 (или выберите ячейку A2 и перетащите ее через ячейку A6).

Введите запятую (,), чтобы отделить первый аргумент от следующего.

Введите второй аргумент C2:C3 (или выведите ячейки с перетаскивания).

Введите закрываю скобки )и нажмите ввод

11)Допустим, в ячейке R1C3 указана формула =R1C1+R1C2. Как только вы введете в ячейки R1C1 и R1C2 числа, результат сложения этих чисел отобразится в ячейке R1C3, то есть формула в ячейке R1C3 использует в качестве переменных значения, указанные в ячейках R1C1 и R1C2.

Объяснение:

1)Обратите внимание, теперь и столбцы, и строки пронумерованы цифрами. Каким же образом указываются координаты ячейки в данном случае? Выделите любую ячейку и посмотрите на поле Имя (слева от строки формул). Теперь адрес ячеек выглядит как RXCY, где X – это номер строки, аY– номер столбца; R – это первая буква слова Row (Строка), а C – Column (Столбец).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ ! один из методов криптографии заключается в измерении частоты появляения буквы в тексте. необходимо написать программу, вычисляющую какую часть текста составляет указанная буква. т.е. отношения количества встречания одной буквы к количеству букв в тексте.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kris5009646
MariyaKhanbalaeva585
tenvalerij
alfastore4
shumeikoElena362
alexeytikhonov
Pogosyan Nataliya
Алина1564
horina12
Дмитрий192
Aleksandrovich_Mitoyan1138
vdm4275
Gor Anatolevich
igschuschkov6211
svetrusval