vallzh8328
?>

Напишите программу, которая считывает пять чисел (каж¬дое между 1 и 30 для каждого считанного числа ваша программа должна вывести строку из равного этому числу количества смежных звездочек. например, если ваша программа считывает число семь, она должна вывести .

Информатика

Ответы

Александровна1685
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(5).Select(k->k*'*').Println(NewLine)
end.

Пример
6 17 1 23 13


*
Pgr100
//PascalABC.NET 3.2 сборка 1318

Var
  n,i,j,resi,resj,flag:integer;
begin
flag:=0;
i:=1;
readln(n);
while power(i,3)<n do
  begin
    j:=1;
    while power(j,3)+power(i,3)<=n do
      begin
        if power(j,3)+power(i,3)=n then
        begin
          flag:=1;
          resi:=i;
          resj:=j;
          break;
        end;
        inc(j);
      end;
    if flag=1 then break;
    inc(i);
  end;
if flag=1 then writeln(resi,' ',resj,' ',resj,' ',resi) else writeln('impossible');
end.

Пример ввода:
1008                           //2^3+10^3
Пример вывода:
2 10 10 2
nastya3213868
На одну чашу весов поместим 2 монеты, на другую – монету и гирю. Если весы уравновесятся, то фальшивая монета та, что осталась. За второе взвешивание определим, легче она или тяжелее любой из настоящих монет (или гири). Если же весы не уравновесятся, то наверняка можно утверждать, что настоящей является отложенная монета. Допустим, перевесила чаша, на которой находятся две монеты. Сравним эти монеты при втором взвешивании. Если весы уравновесятся, то фальшивая монета легче, и она находится рядом с гирей. Иначе фальшивой окажется более тяжелая из двух сравниваемых монет.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая считывает пять чисел (каж¬дое между 1 и 30 для каждого считанного числа ваша программа должна вывести строку из равного этому числу количества смежных звездочек. например, если ваша программа считывает число семь, она должна вывести .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kolyabelousow4059
bikemaster
nkochladze
vera141187
yanermarina87
konss2
mnogoz
Тарбаева1243
garikman-flesh486
Print("8", "x", "9", "=", "72", sep"") ​
Konstantinovich alekseevna993
Tatarnikova1507
yuliasam
Ka2ffka141
Акоповна