hadzievamareta44
?>

Ученики школы № 100 любят загадывать загадки. один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. напишите программу, угадывающую задуманные числа.

Информатика

Ответы

stsnab
Var s,p,a,b: integer;
begin
readln(s,p);
a:=round((s+sqrt(s*s-4*p))/2);
b:=s-a;
writeln(a,' ',b);
end.

Пример:
73 1200
48 25
lenalevmax7937
1)
#include <iostream>using namespace std;int main(){ setlocale(LC_ALL, "Russian"); int a, b, c; cin >> a >> b >> c; // Вид по сторонам if (a == b && b == c) { cout << "Равносторонний треугольник" << endl; }
else if (a == b || b == c || a == c) { cout << "Равнобедренный треугольник" << endl; }
else if (a^2 == b^2 + c^2 || b ^ 2 == a ^ 2 + c ^ 2 || c ^ 2 == b ^ 2 + a ^ 2) { cout << "Прямоугольный треугольник" << endl; } return 0;}
masum-2011687
Program pretty;
var
  count, i, d1, d2, d3, d4, d5, d6: integer;
const
  MIN = 189980;
  MAX = 205505;
begin
  count := 0;
  for i := MIN to MAX do
    begin
      d1 := i div 100000;
      d2 := i mod 100000 div 10000;
      d3 := i mod 10000 div 1000;
      d4 := i mod 1000 div 100;
      d5 := i mod 100 div 10;
      d6 := i mod 10;
      if ( (d6 * 100000) + (d5 * 10000) + (d4 * 1000) + (d3 * 100) + (d2 * 10) + d1 ) = i
      then
        count := count + 1;
    end;
  writeln('в промежутке от ', MIN, ' до ', MAX, ' ', count, ' счастливых билетов');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ученики школы № 100 любят загадывать загадки. один ученик задумал два целых числа от 0 до 1000 и сообщил вам их сумму и их произведение. напишите программу, угадывающую задуманные числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

samsakovs7757
lighturist
valya-7777
cosmetic89
fokolimp
eugene869154
Adabir20156806
РубенШафетдинов
pimenov5
valya-7777
ПаршинАндрей1928
heodbxbbshe
korotinadasha07
dobrovolsky-tmz1
info22