1. напишите программу, анализирующую данные датчика в помещении, которая выводит сообщение « ситуация», если температура в комнате превысила 60 с. значение температуры вводится с клавиатуры. vba
Может быть, так: uses graphABC; Begin setfontcolor(clRed); writeln('Белеет парус одинокой'); setfontcolor(clBlue); writeln('В тумане моря голубом!..'); setfontcolor(clDarkOrchid); writeln('Что ищет он в стране далекой?'); setfontcolor(clDeepSkyBlue); writeln('Что кинул он в краю родном?..'); setfontcolor(clDeepPink); writeln('Играют волны - ветер свищет,'); setfontcolor(clMagenta); writeln('И мачта гнётся и скрыпит...'); setfontcolor(clDarkGreen); writeln('Увы! он счастия не ищет'); setfontcolor(clLime); writeln('И не от счастия бежит!'); setfontcolor(clBrown); writeln('Под ним струя светлей лазури,'); setfontcolor(clIndigo); writeln('Над ним луч солнца золотой...') End.
fullhouse9991
19.12.2021
ответ: 2; Решение: 1)6 мегапикс. = 6000000 пикс;
2) Пусть x ширина картинки, тогда y ее длина. Уравнение: X * 1,5Y = 6000000
3) Находим отношение (1,5). Получается уравнение: 6000000 / X * Y = 1,5;
4)Затем по пропорции находим произведение X и Y. Получилось: 6000000 / 1,5 = X * Y; 4000000 = X * Y;
5)Здесь картинка получается квадратом (условно, без уменьшение ширины, без 1,5);
6)Отсюда можно сделать вывод, что умножение Y на 1,5 дает ответ 3, а разрешение картинки равно: X * Y = 2 * 3 = 6 мегапикс.
P. S. Извиняюсь, что немного муторно, но Информатика есть инорматика...
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
1. напишите программу, анализирующую данные датчика в помещении, которая выводит сообщение « ситуация», если температура в комнате превысила 60 с. значение температуры вводится с клавиатуры. vba
using namespace std;
int main()
{
setlocale(LC_ALL,"Russian");
float a;
cin>>a;
if(a>60)
cout<<"Пожароопасная ситуация";
return 0;
}