nickname0091
?>

Написать программу в с++ дано натуральное число. определить, сколько раз в нём встречается максимальная цифра.

Информатика

Ответы

maximpr6
#include <iostream>
using namespace std;
int A[20];

int main()
{
int n, c, p, max;
int counter, ncounter;
counter = 0;
cin >> n;
c = n;
p = n;
for (c; c>0;)
{
 counter++;
  c = c / 10;
 A[counter] = p - c * 10;
 p = c;
 if (c > 0 && c < 10)
 {
  A[counter + 1] = c;
 }
}
max = 0;
ncounter = 0;
for (int s = 1; s <= counter; s++)
{
 if (A[s] > max)
 {
  max = A[s];
  ncounter = 0;
 }
 if (A[s] == max)
 {
  ncounter++;
 }
}
cout << ncounter;
system("pause");
return 0;
}
Chausmonk4

Да́тчик, сенсор — конструктивно обособленное устройство, содержащее один или несколько первичных измерительных преобразователей. Датчик предназначен для выработки сигнала измерительной информации в форме, удобной для передачи, дальнейшего преобразования, обработки и (или) хранения, но не поддающейся непосредственному восприятию наблюдателем.

Датчик может дополнительно содержать промежуточные измерительные преобразователи, а также меру. Датчик может быть вынесен на значительное расстояние от устройства, принимающего его сигналы. При нормированном соотношении значения величины на выходе датчика с соответствующим значением входной величины датчик является средством измерений.

В настоящее время термины «датчик» и «сенсор» используются как равнозначные для обозначения измерительного преобразователя, выполняющего функции восприятия входной величины и формирования измерительного сигнала, хотя термин «сенсор» акцентирует внимание на восприятии входной величины, а термин «датчик» — на формировании и выдаче измерительного сигнала (данных).

Многофункциональные датчики могут воспринимать и преобразовывать нескольких входных величин, и, помимо основной функции (восприятие величины и формирование измерительного сигнала) выполнять ряд дополнительных функций, таких как функции фильтрации, обработки сигналов и т.п.

Датчики широко используются в научных исследованиях, испытаниях, контроле качества, телеметрии, системах автоматизированного управления и в других областях деятельности и системах, где требуется получение измерительной информации.

Объяснение:

чел ты не дал картинку иза этого я просто напишу что такое датчик

Александра-Андрей909

nomer3

program ab;

uses crt

uses sysutils;

var s,s1: string;

i,j: integer;

begin

clrscr;

write('введите строку слово');

writeln;

readln(s);

for i: =1 to length(s) do

for j: =1 to length(s) do

if (s[i]=s[j]) and(i< > j)

then

if pos(s[i], s1)=0

then s1: =s1+s[i]+' ';

write('повторяющиеся символы: ', s1);

readln;

end.

nomer2

program as

uses crt;

var s,sp: string;

i: integer;

begin

clrscr;

write('s=');

readln(s);

sp: ='';

for i: =1 to length(s) do

sp: =s[i]+sp;

if sp=s then writeln ('палиндром')

else writeln ('не палиндром');

readkey

end.

nomer1

function compare(s1,s2: string): boolean;

begin

result: =s1=s2;

end;

var s1,s2: string;

begin

readln(s1);

readln(s2);

if compare(s1,s2) then write('yes')

else write('no')

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в с++ дано натуральное число. определить, сколько раз в нём встречается максимальная цифра.
Ваше имя (никнейм)*
Email*
Комментарий*
▲