samogon-mozhaisk
?>

Написать программу для вычисления выражения: (тут дроби) a/b*d/c-a-bc/c+d , если a=1 , b=2, c=1, d=0

Информатика

Ответы

васильевич
// pascalabc.net (версия 3.1, сборка 1210 от 29.03.2016) var a: array of integer;               i,n: integer; begin //заполняем массив сл. числами и выводим //массив нумеруется с 0 write('число элементов массива '); readln(n); setlength(a,n); for i: =0 to n-1 do begin   a[i]: =random(21)-10;   write(a[i]: 4); end; writeln; //вывод элементов с неч. номерами в обратном порядке for i: =n-1 downto 0 do   if i mod 2 < > 0 then write(a[i]: 4); end. тестовое решение: число элементов массива 8   -2    2  -6  -5    1    3  -7 -10   -10    3  -5    2
Ивановна_Маликова1549
Всего 3 партии: второй: 14; первый: 24. 1) второй в третьей партии проиграл половину, следовательно 14 - это половина того , что у него было; значит первый в третьей партии выиграл 14, следовательно у него было на 14 меньше. итоги второй партии: второй: 14*2=24; первый: 24-14=10. 2) первый во второй партии проиграл половину , следовательно 10 - это половина того, что у него было; значит второй во второй партии выиграл 10, следовательно у него было на 10 меньше. итого первой партии: второй: 28-10=18; первый: 10*2=20. 3) второй в первой партии проиграл половину, следовательно 18- это половина того, что у него было; значит первый в первой партии выиграл 18, следовательно у него было на 18 меньше. итоги до начала игры: второй: 18*2=36; первый: 20-18=2. ответ : 2 монеты было у первого пирата до начала игры. проверка: второй: (36: 2+10): 2=14; первый: (2+18): 2+14=24.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для вычисления выражения: (тут дроби) a/b*d/c-a-bc/c+d , если a=1 , b=2, c=1, d=0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gorbunova188
ibird777
ГармаеваЕкатерина1637
Dom540703174
muzaffarovich-Sergei1777
veraplucnika
musaevartur
gbelihina
РобертИрина
Антон-Марина
Kamil
turovskaya69
чухловина209
memmedovallahverdi0239
yok887062