nrostovtseva142
?>

Программа на с++() напишите программу, которая сортирует массив целых чисел и определяет количество различных значений в нём. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в первой строке элементы массива, отсортированного в порядке возрастания, а во второй строке – количество различных чисел в массиве. примеры входные данные 6 6 2 1 3 6 2 выходные данные 1 2 2 3 6 6 4

Информатика

Ответы

chavagorin
#include <iostream>
#include <algorithm>

using namespace std;

void sort(int a[], int n) { 
for (int i = 0; i < n; i++) {   
   int j = i;   
   while (j > 0 && a[j - 1] > a[j]) {       
         if (a[j - 1] > a[j]) {         
           swap(a[j - 1], a[j]);       
         }     
        j--;   
      } 
    }
}

int main() {
int n;
cin >> n;
int count = 0;
int *a = new int[n];
for (int i = 0; i < n; i++) {
 cin >> a[i];
}
sort(a, n);
for (int i = 0; i < n; i++) {
 if (a[i] != a[i + 1]) {
  count++;
 }
 cout << a[i] << " ";
}
cout << endl << count;
delete[]a;
}
st7307
Первым великим изобретением древнего Китая считается бумага. Согласно китайским летописям династии Восточная Хань, бумагу изобрел придворный евнух династии Хань — Цай Лун в 105 году н.э.

В глубокой древности в Китае до появления бумаги для записей использовали скрученные в свитки полоски из бамбука, свитки из шелка, деревянные и глиняные таблички и т.д. Наиболее же древние китайские тексты или «цзягувэнь» были обнаружены на черепашьих панцирях, которые датируются 2-м тысячелетием до н. э. (династия Шан).

В ІІІ веке бумагу уже широко применяли для письма вместо более дорогих традиционных материалов. Разработанная Цай Лунем технология производства бумаги состояла в следующем: кипящая смесь из пеньки, коры тутового дерева, старых рыболовных сетей и тканей превращалась в пульпу, после чего её растирали до пастообразного однородного состояния и смешивали с водой. В смесь погружали сито в деревянной раме из тростника, вычерпывали ситом массу и встряхивали, чтобы жидкость стекла. При этом в сите образовывался тонкий и ровный слой волокнистой массы.

Эту массу затем опрокидывали на гладкие доски. Доски с отливками клали одна на другую. Связывали стопку и укладывали сверху груз. Затем затвердевшие и окрепшие под прессом листы снимались с досок и сушились. Изготовленный по такой технологии бумажный лист получался легким, ровным, прочным, менее желтым и более удобным для письма.
Shevtsov1818
Для изготовления двух видов изделий I и II используются три вида сырья.На производство единицы изделия I требуется затратить сырья первого вида 13 кг, сырья второго вида — 32 кг, сырья третьего вида — 58 кг.На производство единицы изделия II требуется затратить сырья первого вида 24 кг, сырья второго вида — 32 кг и сырья третьего вида — 29 кг.Производство обеспечено сырьем первого вида в количестве 312 кг, сырьем второго вида — 480 кг, сырьем третьего вида — 696 кг.Прибыль от реализации единицы готового изделия I составляет 4 усл. ед., а изделия II — 3 усл. ед.Требуется составить план производства изделий I и II, обеспечивающий максимальную прибыль от их реализации, если заранее планируется изготовление не менее 10 единиц изделий I и II.Решение. Рассмотрим математическую модель задачи. Если за *1 взять количество изделий I, планируемых к выпуску, а за.¾ — количество изделий II, то получим задачу линейного программирования.найти максимум линейной функции

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа на с++() напишите программу, которая сортирует массив целых чисел и определяет количество различных значений в нём. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в первой строке элементы массива, отсортированного в порядке возрастания, а во второй строке – количество различных чисел в массиве. примеры входные данные 6 6 2 1 3 6 2 выходные данные 1 2 2 3 6 6 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

laktionova-natal
pelagia-kola2658
tyrenumberone
semenovakotya577
evolkova-73
zamkova836
oleonov
MikhailSvetlana
Кирилл-Анна1023
Александр Джабраиловна1967
jenek-f
Tamara
victoriadan
annakuznetsova841
abahtina582