mdclcompany
?>

Составить программу вычисления площади прямоугольника если известно его одну сторону и длину окружности описанной около него pascal

Информатика

Ответы

irkm8
Var a,c,d,b,s:real;
begin
readln(a,c);
d:=c/pi;
b:=sqrt(d*d-a*a);
s:=a*b;
writeln('s = ',s:5:1);
end.

Пример:
3.0 15.7
s = 12.0
mar1030
var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.
alenih13
Program p_2; var    z, a : real; m : integer; function step (n: integer; x: real): real; var    i: integer; y: real;       begin      i: =1; y: =1;           while i< =n do              begin          y: =y*x; i: =i+1;               end;                   step: =y;           end;   {конец функции}begin    write(‘введи степень и возводимое число’); readln(z,m);     f: =step(m,z);     writeln(z, ‘ в степени’, m, ‘=’,f); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления площади прямоугольника если известно его одну сторону и длину окружности описанной около него pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

axo4937
впвыпвып-Зуйков629
kuziv31
Viktoriya
om805633748
perminovaea
ирина Альбертовна
alexander4590
uuks2012
natapetrova20017
igraparkGP51
platan3698952
Вера1072
Горина
egoryandiana3727283
▲