алексеевич810
?>

на кану оценка за четверть . нужно написать программу которая проверяет у тебя таблицу умножения, машина должна дать 10 примеров и показать результат. причём чтоб они не повторялись. мы должны вбивать в конце одно число. это ответ в каждом примере

Информатика

Ответы

ovdei71
Var
a,b,i,z:integer;
Begin
ClrScr;
Randomize;
for i:=1 to 10 do
 begin
 a:=random(9)+1;
 b:=random(9)+1;
 write(a,'*',b,' = ');
 readln(z);
 if z=a*b then writeln('Верно!')
 else  writeln('Не верно! ',a,'*',b,' = ',a*b);
 end;
readln;
end.

Пример (для 3 заданий):
6*6 = 36
Верно!
8*3 = 26
Не верно! 8*3 = 24
2*4 = 8
Верно!
ВладимировнаАлександр1421
Program z1;
Uses Crt;
Var
z:integer;
Begin
ClrScr;
writeln('1*2=?');
readln(z);
if z=2 then writeln('Верно!')
else  writeln('Не верно! 1*2=2');
writeln('2*3=?');
readln(z);
if z=6 then writeln('Верно!')
else  writeln('Не верно! 2*3=6');
writeln('3*6=?');
readln(z);
if z=18 then writeln('Верно!')
else  writeln('Не верно! 3*6=18');
writeln('4*7=?');
readln(z);
if z=28 then writeln('Верно!')
else  writeln('Не верно! 4*7=28'); 
writeln('5*9=?');
readln(z);
if z=45 then writeln('Верно!')
else  writeln('Не верно! 5*9=45');
writeln('6*4=?');
readln(z);
if z=24 then writeln('Верно!')
else  writeln('Не верно! 6*4=24');
writeln('7*7=?');
readln(z);
if z=49 then writeln('Верно!')
else  writeln('Не верно! 7*7=49');
writeln ('8*6=?');
readln(z);
if z=48 then writeln('Верно!')
else  writeln('Не верно! 8*6=48');
writeln('9*4=?');
readln(z);
if z=36 then writeln('Верно!')
else  writeln('Не верно! 9*4=36');
writeln('10*8=?');
readln(z);
if z=80 then writeln('Верно!')
else  writeln('Не верно! 10*8=80');
readln;
end.
anazarov80
Var a: array of integer; // Объявление массива целых чисел
  i, n: integer; // объявление целочисленных переменных
begin
  // Запросим с клавиатуры размер массива
  // и запишем его в переменную n
  write('введите n:'); 
  readln(n);
  
  // Теперь выделим память под n элементов массива
  SetLength(a, n);
  
  // теперь запросим с клавиатуры n чисел для массива
  for i := 0 to n-1 do begin
    write('a[', i, ']=');
    readln(a[i]);
  end;
  
  // теперь в цикле уменьшим каждый элемент на единицу
  for i := 0 to n-1 do 
    a[i] := a[i] - 1;
  
  // распечатаем массив
  for i := 0 to n-1 do 
    write(a[i], ' ');
end.
dashanna04225
Если при сложении с единицей в некоторой системе счисления из двухзначного числа получается трехзначное, то двухзначное число было максимально возможным двухзначным числом, записанным в этой системе и обе его цифры были на единицу меньше основания системы счисления.Таким образом, можно утверждать, что заданные числа это 33₄, 66₇, 88₉Число 100 в системе счисления по оcнованию n равно n², т.е. для указанных чисел это будут значения 4²=16, 7²=49 и 9²=81. Остается вычесть единицу.Соответственно, в десятичной системе 33₄=15, 66₇=48, 88₉=80

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

на кану оценка за четверть . нужно написать программу которая проверяет у тебя таблицу умножения, машина должна дать 10 примеров и показать результат. причём чтоб они не повторялись. мы должны вбивать в конце одно число. это ответ в каждом примере
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ibswoklol1362
Середа-Сергеенков980
galinasemyan689
martinson
Динков
jablokov
zaotar2008
Ka-tja78
Nastyakarysheva8750
olgavbaranova
Alekseevna1811
neblondinka19
snopok66
ПолухинаТененева565
Тимур Андраниковна634
▲