katushak29
?>

Python 3.напишите программу, которая вычисляет сумму и произведение целых чисел, поданных на её вход. ввод заканчивается числом 0. \\ с описанием!

Информатика

Ответы

Nekrasova
Summa = 0; #переменная суммыproizvedenie = 1 #переменная произведения начинается с 1 тк если умножить на 0 будет 0i = int(input()) #ввожу первое число while i != 0 :  #цикл с условием пока вводимое число не будет равнятся 0  summa+=i  #суммирую  proizvedenie*=i  #умножаю  i = int(input()) # ввожу новое первое число и если оно не равняется нулю цикл повторитсяprint(summa)#вывожу суммуprint(proizvedenie)#вывожу произведение
ekvld708

Пояснение:

Если ввод осуществляется через файл, то он должен называть "Слова.txt" и находиться в одной директории с исполняемым файлом. Выбрать нужный вариант ввода можно просто введя цифру в перовом input.

Код:

# -*- coding: utf-8 -*-

format = int(input("Считать слова из файла (введите 1)\nВводить слова в консоль (введите 2)\nВвести слова в одну строку(введите 3)\nВыбор: "))

words = []

answer = []

if format == 1:

  f = open('Слова.txt', "r", encoding='utf-8')

  line = f.readline()

  while line:

      for i in line.split(", "):

          words.append(i)

      line = f.readline()

  f.close()

elif format == 2:

  n = int(input("Введите кол-во слов - "))

  for i in range(n):

      words.append(input("Вв. слол - "))

elif format == 3:

  n = input("Введите строку - ")

  for i in n.split(", "):

      words.append(i)

else:

  print("Неправильно введен номер ответа")

word = input("Введите поисковое слово - ")

for i in words:

  for j in list(word):

      if len(set(word).intersection(set(i))) == len(i):

          answer.append(i)

          break

print(", ".join(answer))

Текст для документа:

рыба, рак, щука, лебедь, карась, пескарь, баня, бубен, столб, баян, барыня

TatianaSeliverstova64

===== PascalABC.NET =====

begin

 var СписокСлов := ReadlnString('Список слов через пробел:').ToWords;

 var ИсходныйСловарь := new Dictionary<char, integer>;

 var РабочийСловарь := new Dictionary<char, integer>;

 foreach var Символ in ReadlnString('Слово:') do

   ИсходныйСловарь[Символ] := ИсходныйСловарь.Get(Символ) + 1;

 var СтрокаВывода: string;

 foreach var Слово in СписокСлов do

 begin  

   foreach var Символ in Слово do

     РабочийСловарь[Символ] := РабочийСловарь.Get(Символ) + 1;

   var МожноПостроитьСлово := True;

   foreach var ЭлементРабочегоСловаря in РабочийСловарь do

   begin

     var Ключ := ЭлементРабочегоСловаря.Key;

     var ПределПовторовБуквы: integer;

     if ИсходныйСловарь.TryGetValue(Ключ, ПределПовторовБуквы) then

     begin  

       if ЭлементРабочегоСловаря.Value > ПределПовторовБуквы then

       begin

         МожноПостроитьСлово := False;

         break

       end

     end

     else

     begin

       МожноПостроитьСлово := False;

       break

     end  

   end;  

   if МожноПостроитьСлово then

   begin

     if СтрокаВывода <> '' then

       СтрокаВывода += ', ';

     СтрокаВывода += Слово

   end;  

   РабочийСловарь.Clear;

 end;

 Println(СтрокаВывода)

end.


Реализовать любом языке из списка: си/c++/c#/pascal/basic/javascript/fasm. задано для развлечения =)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python 3.напишите программу, которая вычисляет сумму и произведение целых чисел, поданных на её вход. ввод заканчивается числом 0. \\ с описанием!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anna Artem
Faed_Arakcheeva
sanhimki47
stusha78938
bryzgalovag
zdanovich90764
mez-omts-d5
Роман_Гречина
laleonaretouch
kapi30
buriginast5
Платон Демцун
Kashirina
pechatlogo4
Алена