SERGEI124
?>

Сpython! напишите программу, которая находит рекордное количество вхождений (не обязательно подряд) символа в строку. формат ввода вводится одна строка. формат вывода выводится одно целое число — максимальное количество раз, которое встречается какая-либо буква (без учёта регистра) или иной символ во введённой строке. пример ввод: вывод: 4

Информатика

Ответы

alekbur
S = input("Bвeдитe строку:\n")
s = s.upper()
k = 0
for i in range(0,len(s)):
    if s.count(s[i])>k: k = s.count(s[i])
print(k)

Пример:
Длинношеееддд
4
Dushko

Задание 1

a)

program pr;

var

s:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

writeln('Введите заданный символ');

readln (c);

for i:=1 to length(s) do if s[i]=c then writeln ('В строке найден заданный символ');

readln;

end.

б)

program pr;

var

s,n:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

writeln(n);

readln;

end.

в)

program pr;

var

s,n,f:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

f:=copy(s,i+1,length(s)-i+1);

writeln(n);

writeln(f);

readln;

end.

Задание2

program pr;

var s:string;

begin

s:='Касіу Ясь канюшыну';

delete (s,7,3);

insert ('Слово которое хотите вставить',s,7);

writeln (s);

readln;

end.

 

agent-ulitka5

Паскаль

Откомпилирован: (Pascal ABC)


program z1;
uses crt;
var
   n: integer;
   i: integer;
begin
    write(' Введите n :  ');
    readln(n);
   
    for i := 1 to n do
    begin
         writeln(' Число:',i,' Степень:', i *i);
    end;
end.

 

Си

Откомпилирован: (DEV Cpp)

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>
#include <math.h>

int main()
{
 int n = 0;
 
 printf("\n Vvedite n:  ");
 scanf("%d", &n);

 printf("\n Chislo | Stepen");
 for(int i = 1; i < n; i++)
 {
         printf("\n %5d  |%5d ", i, i * i);
 }

 getch( );

 return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сpython! напишите программу, которая находит рекордное количество вхождений (не обязательно подряд) символа в строку. формат ввода вводится одна строка. формат вывода выводится одно целое число — максимальное количество раз, которое встречается какая-либо буква (без учёта регистра) или иной символ во введённой строке. пример ввод: вывод: 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sveta740450
tashovairina
Sdiuh iuw h 87yr e8iudshiu hdd?
AMR89154331531
arnaut-anna
sawa-msk
sergeychelyshev197618
Дмитриевич Бирковская69
tenvalerij
tretyakovamarina201155
olgapotapova
boykovandrew6663
dimoni86
lovel24
pavlova7771960
Leobed917670
▲