Исполнитель-объект,который выполняет алгоритм.
Есть 2 типа исполнителей:
Формальные и неформальные
Формальные не вносят никаких изменений в алгоритм.
Неформальные могут вносить изменения в алгоритм.
В роли формального исполнителя чаще всего выступает техническое устройство.
В роли неформального исполнителя чаще всего выступает человек.
За действия формального исполнителя отвечает управляющий им объект.
Неформальный исполнитель сам отвечает за свои действия,но не всегда может выполнять те же команды одинаково.
А формальный исполнитель может всегда одинаково выполнять одну и ту же команду.
Объяснение:
Объяснение:
Текст "В Лесу" Как красиво в осеннем лесу! Каждое дерево имеет свой особенный наряд. Пожелтели листья берёзы. Покраснели листья клёна и осины. Листья дуба стали тёмно-зелёными. Осенью в лесу спокойно. Звери попрятались:готовятся к зиме. Птицы кричат высоко в небе. Они собираются в стаи, чтобы лететь на юг. Солнце еще греет, но воздух уже холодный. По прозрачному небу бегут облака.
<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<title>"В Лесу"</title>
<style>
h2{
text-align: center;
}
p{
text-align: center;
}
</style>
</head>
<body>
<h2><b><i>Текст "В Лесу"</b></i></h2>
<p><font size="4" color="Red" face="Arial">Как красиво в осеннем лесу!</font></p>
<p><font size="4" color="Orange" face="Arial">Каждое дерево имеет свой особенный наряд.</font></p>
<p><font size="4" color="Yellow" face="Arial">Пожелтели листья берёзы.</font></p>
<p><font size="4" color="Green" face="Arial">Покраснели листья клёна и осины.</font></p>
<p><font size="4" color="Cyan" face="Arial">Листья дуба стали тёмно-зелёными.</font></p>
<p><font size="4" color="Blue" face="Arial">Осенью в лесу спокойно.</font></p>
<p><font size="4" color="Purple" face="Arial">Звери попрятались:готовятся к зиме.</font></p>
<p><font size="4" color="red" face="Arial">Птицы кричат высоко в небе.</font></p>
<p><font size="4" color="Orange" face="Arial">Они собираются в стаи, чтобы лететь на юг.</font></p>
<p><font size="4" color="Yellow" face="Arial">Солнце еще греет, но воздух уже холодный.</font></p>
<p><font size="4" color="Green" face="Arial">По прозрачному небу бегут облака.</font></p>
</body>
</html>
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу на языке c++! дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя!
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}