Объяснение:
Допустим, у нас есть сообщение «habr», которое необходимо передать без ошибок. Для этого сначала нужно наше сообщение закодировать при Кода Хэмминга. Нам необходимо представить его в бинарном виде.На этом этапе стоит определиться с, так называемой, длиной информационного слова, то есть длиной строки из нулей и единиц, которые мы будем кодировать. Допустим, у нас длина слова будет равна 16. Таким образом, нам необходимо разделить наше исходное сообщение («habr») на блоки по 16 бит, которые мы будем потом кодировать отдельно друг от друга. Так как один символ занимает в памяти 8 бит, то в одно кодируемое слово помещается ровно два ASCII символа. Итак, мы получили две бинарные строки по 16 битбит. распараллеливается, и две части сообщения («ha» и «br») кодируются независимо друг от друга. Рассмотрим, как это делается на примере первой части.
Прежде всего, необходимо вставить контрольные биты. Они вставляются в строго определённых местах — это позиции с номерами, равными степеням двойки. В нашем случае (при длине информационного слова в 16 бит) это будут позиции 1, 2, 4, 8, 16. Соответственно, у нас получилось 5 контрольных бит (выделены красным цветом)Таким образом, длина всего сообщения увеличилась на 5 бит. До вычисления самих контрольных бит, мы присвоили им значение «0».
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу на паскале.сформировать с датчика случайных чисел массива a[1..3, 1..6], элементы которого находятся в промежутке от -20 до 20 .удалить n строку массива.
// Внимание! Если программа не работает, обновите версию!
begin
var k:=3;
Writeln('*** Исходный массив ***');
var a:=MatrRandom(k,6,-20,20);
a.Println(4); Writeln(4*a.ColCount*'-');
var n:=ReadInteger('Какую строку удалить (1-'+k+')?');
Assert(n.Between(1,k),'Введено неверное значение');
var r:=a.Row(k-1); // последняя строка
SetLength(a,k-1,a.ColCount); // теперь строк на одну меньше
if n<k then begin
for var i:=n-1 to k-3 do
a.SetRow(i,a.Row(i+1));
a.SetRow(k-2,r)
end;
Writeln(4*a.ColCount*'-'); a.Println(4)
end.
Примеры
*** Исходный массив ***
-8 3 -10 -5 -8 11
14 -5 -19 -6 -19 -15
0 -11 11 3 -6 -12
Какую строку удалить (1-3)? 1
14 -5 -19 -6 -19 -15
0 -11 11 3 -6 -12
*** Исходный массив ***
11 -14 -3 18 19 -9
-11 19 8 20 -19 19
-20 13 3 -13 13 1
Какую строку удалить (1-3)? 3
11 -14 -3 18 19 -9
-11 19 8 20 -19 19