Narine natalya
?>

Идет к-ая секунда суток. определите, сколько полных часов (h) и полных минут (м к этому моменту. (например, если к=13257=3*3600+40*60+57, то h=3 и m=40) надо написать программу на основе pascalabc

Информатика

Ответы

alexander4590
Var K, M, H: longint;
Begin
WriteLn('Введите номер секунды');
ReadLn(K);
H:=K div 3600;
M:=(K-H*3600) div 60;
K:=K-H*3600-M*60;
часов: ', H, '; минут: ', M, '; секунд: ', K);
Sleep(5000);
End.
morsh9345
Таблицы позволяют объединить однотипные данные в более-менее читабельную структуру, чего не делает словесное описание (как, например, приятней читать таблицу с датами и описанием исторических событий в таблице, чем читать словесную демагогию в учебиках). Таблицы позволяют ужать данные в размере, читателю сосредоточиться на главном. Они позволяют операторам обрабатывать её без каких-либо затруднений.

Еще пример: магазинные чеки. Не будет же машина (из-за технической сложности) или человек (из-за лени) писать на чеке: "продано столько-то столько-то того-то того-то ... пакет апельсинов весил шестьсот пядесят три грамма ... итд". На чеке будет табличка, где четко и точно будет написано то, что человек приобрел.
Вот. Так что табличные модели, несомненно, лучше словесных.
hellomaxim
Компьютер — самый необычный инструмент из всех придуманных человеком. Он используется не в материальной, а в умственной, интеллектуальной деятельности людей разных профессий: экономистов, конструкторов, переводчиков, психологов, физиков, художников...

Возможности своего интеллектуального человек постоянно старается расширить. Для этого не только совершенствуется оборудование, «железо» компьютера, но и создаются новые компьютерные программы, программные средства. Эти программы составляются программистами — специалистами в области информатики.


Зачем нужны компьютерные программы? Компьютер часто называют «умной» машиной, однако он не обладает человеческим разумом. Человек действует, когда захочет этого сам, или по заданию других людей. Компьютер ничего не делает «по собственному хотению». Все действия он выполняет только по заданию человека. Для управления действиями компьютера и предназначены компьютерные программы.

Могут ли программисты составлять компьютерные программы без участия других специалистов? Пусть, например, программа предназначена для авиаконструктора или модельера-парикмахера, тогда программисту потребуется представителей этих профессий. Только специалисты смогут подробно рассказать, с какими предметами, персонажами и явлениями они имеют дело в своей работе, что может происходить со всеми этими объектами, как принимаются решения. На месте такого специалиста может оказаться в будущем любой из вас, какую бы профессию он ни выбрал.

 Может ли человек, не изучавший информатику, рассказать о своей работе, учебе или любимой игре? Наверное, да. Но одно дело, когда рассказ предназначен для другого человека, и совсем другое, когда сведения нужны для создания компьютерной программы. Объясняя что-то людям, мы можем не вдаваться в какие-то подробности, полагаясь на их опыт, знания, сообразительность. В описаниях, которые составляются при создании компьютерных программ, не должно быть ничего лишнего, но в то же время они не могут полагаться на чей-то опыт или смекалку.

 И еще: эти описания нужно представить не в форме устного рассказа или повести, а в виде наглядных и компактных схем, таблиц, списков. Составлению таких «компьютерных» описаний нужно специально учиться — изучать информатику. Полученные знания и умения можно использовать не только при создании компьютерных программ. Они пригодятся всем, кому приходится составлять описания, инструкции, объяснения. А ведь делать это приходится практически каждому человеку — в любом возрасте и в самых различных ситуациях. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Идет к-ая секунда суток. определите, сколько полных часов (h) и полных минут (м к этому моменту. (например, если к=13257=3*3600+40*60+57, то h=3 и m=40) надо написать программу на основе pascalabc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

myatadinamo
admiralbany
ivanrancev
ПодлеснаяМакарова1883
asvirskiy26
kashxb2056
Kushchenko-Monashev
ea9824165833886
mon84
bike-garage8
marinamarinazmeeva2444
Игоревна Худанов1150
Александровна1973
olgamalochinska
ilma20168