Анастасия Елена
?>

1. составить программу расчета значения функции z = |3 е^х+3 – 2 ln ху| + 1, 8х^2 + 1 при любых значениях х и у. результат вывести в виде: при х= … и у=… z=… составить, .

Информатика

Ответы

Болеславовна
var
  x, y, z: real;
begin
  write('Введите x = ');
  readln(x);
  write('Введите y = ');
  readln(y);
  z := abs(3*exp(3)+3-2*ln(x) * y) + 1.8*sqr(x) + 1;
  writeln('z = ', z:4:4);
end.

1. составить программу расчета значения функции z = |3 е^х+3 – 2 ln ху| + 1,8х^2 + 1 при любых значе
Рамиль211
Каждый из возможных символов должен использовать минимально возможное количество БИТ, следовательно :
25 букв + 10 цифр = 35 символов.
Для их хранения требуется узнать минимальное количество бит, (Степень цифры 2), поэтому:
( так как 2^5 < 35 < 2^6) получается, что использовать менее 6 бит нельзя. Таким образом, при 6 битах на символ, номер, содержащий 7 символов определяется:
7 * 6 = 42 бита.
Так как номер записывается минимально возможным количеством БАЙТ, то объём его в БИТАХ должен быть кратен 8 и в случае необходимости округляться в большую сторону.
Ближайшее число кратное 8 - это 48.
48 / 8 = 6 байт.
6 БАЙТ занимает 1 номер. 
Таким образом, 6 * 80 = 480 байт.

Сошлось или же я что-то упустил? 
Anastasiya Yevseeva948
У каждой лошади свой уникальный номер, то есть количество номеров равно 20. 
Для кодирования двадцати различных значений требуется как минимум 5 бит.
Разберёмся, почему именно пять бит:
Кол-во комбинаций, которые мы можем закодировать неким количеством бит, вычисляется по формуле 2^i, где i - количество бит, которое нужно для кодирования такого количества комбинаций.
Если мы возьмем 4 бита, то сможем закодировать максимум 2^4=16 комбинаций, не хватает. Пятью битами мы можем закодировать 2^5=32 комбинации, чего достаточно.

Во фразе "только 15 и 20", видимо, была пропущена буква "з", то есть можно прочитать как "только 15 из 20".

На финиш пришло 15 лошадей, номер каждой занимает 5 бит, общее количество бит равно 15*5 = 75 бит.

ответ: 75

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составить программу расчета значения функции z = |3 е^х+3 – 2 ln ху| + 1, 8х^2 + 1 при любых значениях х и у. результат вывести в виде: при х= … и у=… z=… составить, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Valerevna
Aleksei Aleksandrovna649
bulk91675
Aleksandr740
juliaipatova1739
Дмитрий_Пергамент669
andrey4work918
and-syr
Vs1377
NurlanAleksandrovich
Kotvitskii
Суравцова_Алексей669
artemyanovich8
fitzhu
DzukaevAlekseevich