Avolohova
?>

9класс ! напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности и сумму чётных чисел.

Информатика

Ответы

vladislavk-market2
Var a,n,s:integer;
begin
n:=0; s:=0;
readln(a);
while a<>0 do
 begin
 n:=n+1;
 if a mod 2=0 then s:=s+a;
 readln(a);
 end;
writeln('n = ',n,'  s = ',s);
end.

Пример:
5
2
8
7
3
0
n = 5 s = 10
omraleva

ЖарайдыКестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.Кестеде органикалық заттар мен олардың маңыздылығын көрсететін ақпарат берілген. Кестені қажетті ақпаратпен толықтыр.

anadtacia03108988
Program textFind;
uses StrUtils;
var text,buffer : String;
var tpos,lastpos,counter,biggest : Integer;
begin
  tpos := 0;
  text := '';
  while(tpos = 0) do begin
    readln(buffer);
    text += buffer;
    tpos := pos('.',buffer)
  end;
  lastpos := 1;
  tpos := PosEx(' ',text,lastpos);
  if tpos = 0 then 
    tpos := PosEx('.',text,lastpos);
  biggest := tpos-1;  lastpos := tpos+1;
  while(not (tpos = 0)) do begin
    tpos := PosEx(' ',text,lastpos);
    if tpos = 0 then
        tpos := PosEx('.',text,lastpos);
    if (tpos-lastpos) > biggest then
        biggest := tpos-lastpos; 
   lastpos := tpos+1;
  end;
  lastpos := 1;  counter := 0;
  tpos := PosEx(' ',text,lastpos);
  if tpos = 0 then
    tpos := PosEx('.',text,lastpos);
  while(not (tpos = 0)) do begin
    if (tpos-lastpos) = biggest then
        counter += 1;
    lastpos := tpos + 1;
    tpos := PosEx(' ',text,lastpos);
    if tpos = 0 then
        tpos := PosEx('.',text,lastpos);
  end;
writeln(counter);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

9класс ! напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности и сумму чётных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Segyn1218
kmr495270
gurman171
Yelena1409
Герасименко
stic1995
hr2251
milkamilka1998
tashovairina
struev2003260
lion13
lepekhov4011
apioslk4533
Антон
fox-cab3444