Никитина580
?>

Ваш отпуск длится f дней. Сколько полных недель и дней составляет ваш отпуск?Входные данные:52Выходные данные:52 дней(я) - 7 недель 3 дней (я)НАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕ

Информатика

Ответы

tumanowivan2015509
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
flag,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          flag:=1;
if flag=1 then
   writeln('Yes')
else
   writeln('N');
end.

вариант 2
const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
k,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          k:=k+1;
if k<>0 then
   writeln('Yes')
else
   writeln('N');
end.
yakovlevasvetlanalvovna209
Программа Вот:
Program z1;Var a,b,c,d,k:integer;BeginWriteln('Введите трехзначное число');REadln(a);While a<>0 do beginWriteln('Введите трехзначное число');REadln(a);b:=a div 100 mod 10;c:=a div 10 mod 10;d:=a mod 10;if b+c+d div 10 >0 then writeln('Сумма цифр- двузначное число') else writeln ('Нет, сумма цифр не двузначное число');if b*C*D div 100 >0 then writeln('Произведение цифр- терхзначное число') else writeln ('Нет, произведение цифр не трехзначное число число');Writeln ('Введите любое число');Readln (k);If b*c*d>k then writeln('Произведение цифр больше числа') else writeln('Произведение меньше числа');if B+c+d div 5 =0 then writeln('Сумма цифр числа кратна 5') else writeln ('Сумма цифр не кратна 5');if B+c+d div k =0 then writeln('Сумма цифр числа кратна числу, введенному с клавиатуры') else writeln ('Сумма цифр не кратна числу, введенному с клавиатуры');End;End. 
Есть маленькая проблема в начале, не помню как прописывать, поэтому число первый раз нужно вводить 2 раза, если не устраевает, можете воспользоваться другими ресурсами  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ваш отпуск длится f дней. Сколько полных недель и дней составляет ваш отпуск?Входные данные:52Выходные данные:52 дней(я) - 7 недель 3 дней (я)НАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sashaleb88
Aleksandrovna Kolesnik1764
iv1as2
madjk
Константин
kol-nat26
Kubataeva Nikolaevich1389
Pavlushina-Novikova
Anatolevna1703
amxvel7596
polusik120796
German
helena-belozerova
endyurans2ooo
Эрендженова