KosarinPotemkina1888
?>

В Python 3. «A»: Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10, 99], и находит максимальный и минимальный элементы в матрице и их индексы. Пример: Матрица А: 12 14 67 45 32 87 45 63 69 45 14 11 40 12 35 15 Максимальный элемент A[2, 2]=87 Минимальный элемент A[3, 4]=11 Очень нужно

Информатика

Ответы

mulyugina365
Вот все числа в ряд (без запятых):

использовать Чертежник
алг
нач
| 1
сместиться на вектор (1,3)
опустить перо
сместиться на вектор (2,2)
сместиться на вектор (0,-4)
поднять перо
| 2
сместиться на вектор (1,3)
опустить перо
сместиться на вектор (0,1)
сместиться на вектор (2,0)
сместиться на вектор (0,-2)
сместиться на вектор (-2,-2)
сместиться на вектор (2,0)
поднять перо
| 3
сместиться на вектор (1,4)
опустить перо
сместиться на вектор (2,0)
сместиться на вектор (-2,-2)
сместиться на вектор (2,0)
сместиться на вектор (-2,-2)
поднять перо
| 4
сместиться на вектор (3,4)
опустить перо
сместиться на вектор (0,-2)
сместиться на вектор (2,0)
поднять перо
сместиться на вектор (0,2)
опустить перо
сместиться на вектор (0,-4)
поднять перо
| 5
сместиться на вектор (3,4)
опустить перо
сместиться на вектор (-2,0)
сместиться на вектор (0,-2)
сместиться на вектор (2,0)
сместиться на вектор (0,-2)
сместиться на вектор (-2,0)
поднять перо
| 6
сместиться на вектор (5,4)
опустить перо
сместиться на вектор (-2,-2)
сместиться на вектор (0,-2)
сместиться на вектор (2,0)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
поднять перо
| 7
сместиться на вектор (3,2)
опустить перо
сместиться на вектор (2,0)
сместиться на вектор (-2,-4)
поднять перо
| 8
сместиться на вектор (3,2)
опустить перо
сместиться на вектор (0,2)
сместиться на вектор (2,0)
сместиться на вектор (0,-4)
сместиться на вектор (-2,0)
сместиться на вектор (0,2)
сместиться на вектор (2,0)
поднять перо
| 9
сместиться на вектор (1,-2)
опустить перо
сместиться на вектор (2,2)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
сместиться на вектор (0,-2)
сместиться на вектор (2,0)
поднять перо
сместиться на вектор (-27,-3)
кон

Как нарисовать в кумир число 1,2,3,4,5,7,8,9? исполнитель чертежник
Анна-Денис1346
Var
x,y,rast:array [1..100] of Integer ;
n:Integer;

function maxrast(n:Integer;x,y:array [1..100] of integer): real;
var i,j:integer;
max:real;
begin
for i:=1 to n do
for j:=1 to n do
if sqrt(sqr(x[i]-x[j])+sqr(y[i]-y[j]))>max then
max:= sqrt(sqr(x[i]-x[j])+sqr(y[i]-y[j]));
maxrast:=max;
end;

procedure vvod(n:Integer);
var i:integer;
begin
for
i:=1 to n do
begin
WriteLn('Введите координату x ',i,' отрезка');
ReadLn(x[i]);
WriteLn('Введите координату y ',i,' отрезка');
ReadLn(y[i]);
end;
end;

begin
Writeln('Введите количество точек');
ReadLn(n);
vvod(n);
Writeln('Длина наибольшего отрезка составленного из заданных точек = ',maxrast(n,x,y));
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В Python 3. «A»: Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10, 99], и находит максимальный и минимальный элементы в матрице и их индексы. Пример: Матрица А: 12 14 67 45 32 87 45 63 69 45 14 11 40 12 35 15 Максимальный элемент A[2, 2]=87 Минимальный элемент A[3, 4]=11 Очень нужно
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mbykovskiy
gladkihvv
Акимцева27
vnolenev
tcmir
reception
osipovasalex5316
Shevtsov1818
Natalya1895
ngz55
ekasatkina
ksenia15-79
sohrokova809
tatry2005
uvarovig