program z1;
var i,x,y,z,k:integer;
begin
k:=0;
randomize;
writeln ('Проверка знания Таблицы умножения');
writeln;
for i:=1 to 5 do
begin
x:=random(9)+1;
y:=random(9)+1;
writeln ('Сколько будет ',x,' * ',y);
write ('Ваш ответ ');
readln (z);
if z=x*y then
begin
k:=k+1;
writeln ('Правильно!')
end
else writeln ('Неправильно! ',x,' * ',y,' = ',x*y);
writeln
end;
writeln;
writeln ('Количество правильных ответов ',k)
end.
Объяснение:
Цикл с параметром (5 вопросов):
1) Числа генерируются случайным образом от 1 до 9
2) Вывод на экран вопроса
3) Ввод ответа пользователем
4) Оценка правильности ответа (полный оператор ветвления - если ответ пользователя верен, то увеличиваем значение k и выводим сообщение о верности ответа, иначе выводим сообщение об ошибочности ответа и верный ответ)
Вывод на экран количество правильных ответов
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, Котора вычисляет расстояние между двумя точками на плоскости с заданными координатами (X1, Y1), (X2, Y2) Подсказка формула для нахождения расстояния между двумя точками выглядит так d=Корень из ( X2, -X1)-в квадрате + (Y2-Y1)-в квадрате
Создать таблицу и указать её параметры (поля и расстояние между ячейками) через стили.
Решение
Таблица состоит из строк и столбцов ячеек, которые могут содержать текст и рисунки. Для добавления таблицы на веб-страницу используется тег <table>. Этот элемент служит контейнером для элементов, определяющих содержимое таблицы. Любая таблица состоит из строк и ячеек, которые задаются соответственно с тегов <tr> и <td>. Таблица должна содержать хотя бы одну ячейку (пример 1). Допускается вместо тега <td> использовать тег <th>. Текст в ячейке, оформленной с тега <th>, отображается браузером шрифтом жирного начертания и выравнивается по центру ячейки. В остальном, разницы между ячейками, созданными через теги <td> и <th> нет.