antrotip
?>

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. pascal abc

Информатика

Ответы

teya07
Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.
Сергей_Евгеньевич1255
Var
  a:array[1..10] of integer;
  b,i,k:integer;
begin
  Randomize;
  Write('Введите количество элементов в массиве: ');
  for i:=1 to 10 do
  begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  Write('Какое число искать? ');
  Readln(b);
  k:=0;
  for i:=1 to 10 do
    if a[i]=b then Inc(k);
  Writeln('Число встречается ',k,' раз')
end.

Подробнее - на -
АннаМаргарита

ответ на фото. Будут вопросы, спрашивай.

На твоей схеме изображены вентили КМОП. Рекомендую забить в инете "КМОП вентили" узнать что это такое и почитать. Рекомендую изучить логические операции и их таблицы истинности.

Расскажу коротко. На твоей схеме представлены 3 вентиля КМОП.

Вентиль прямоугольник с единицей -это вентиль ИЛИ(логическое сложение). Обрати внимание, что у тебя два таких вентиля. Один из них на выходе имеет кружочек. Это означает, что выходной результат от операции ИЛИ будет инвертироваться, т.е. к нему будет применяться операция "НЕ". т.е если на выходе получилась 1, после применения операции "НЕ" будет 0. Если на выходе был 0, то после операции "НЕ" будет 1.

На твоей схеме есть еще один элемент. Это прямоугольник, внутри которого амперсанд-это логическое И(логическое умножение).

Теперь расскажу, что происходит:

1) Выписываем в таблицу все возможные комбинации переменных. Как видишь у тебя три переменные А, В, С. (первых три столбца).

2) Дальше производим выше перечисленные операции.

Производим логическое сложение переменных А, В(четвертый столбец)

3) Производим отрицание этого результата(т.к. на выходе кружочек-ОТРИЦАНИЕ, операция НЕ). Это пятый столбец.

4) Производим логическое сложение переменных В,С. Это шестой столбец.

5) Производим логическое умножение полученных результатов от операций сложения.(столбец седьмой)

6) производим отрицание полученного результата. Это последний столбец.

УДАЧИ:)


задаю вопрос уже 3 раз, вот все которые остались
davidovalbert6

а=11         b=3

a=11-2     b=b+a

         a<2?-нет,так как 2<9

Возвращаемся в начало:

а=9-2       b=b+3

         7<2?-нет,так как 2<7

Возвращаемся в начало:

а=7-2        b=b+3

        5<2?-нет,так как 2<5

Возвращаемся в начало:

a=5-2        b=b+3

       3<2?-нет,так как 2<3

Возвращаемся в начало:

a=3-2        b=b+3

        1<2?-да,значит идем дальше:

b=b+a (b=3+1)

                4<=1?-нет,идем дальше:

а=а+3        b=b-a

a=4            b=4-4 (0)

Возвращаемся назад:

             0<=1-да,значит:

             Конец.

b=0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei Gaishun
reception
tsypanttn21
Васенкова204
merx80
igortychinin
Маринова
Nurislamovna1543
tochkamail7
Роман1406
НатальяРуктешель472
farmprofi
alislisa191
lescha-77766
kotsur