lor005148
?>

НА ПИТОНЕ С клавиатуры вводится предложение, в котором слова разделены пробелами. Определите, сколько слов в этом предложении заканчивается на букву "а"

Информатика

Ответы

vadimkayunusov

Объяснение:

Var

 n,k,i: integer;

 s:string;

begin

write('Введите фразу: ');

readln(s);

k:=length(s)-1;

if s[1]='а' then n:=1;

for i := 1 to k do

     if (s[i]=' ') and (s[i+1]='а') then n:=n+1;

writeln('Число слов на а(рус.): ',n)

end.

btatarintsev

stroka=input()

spisok=[]

a=stroka.split(' ')

for i in a:

     if i[len(i)-1]='а':

               spisok.append(i)

print(len(spisok))

Объяснение:

ainud
Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.
aci2003

var

a,i,n,a1:integer;

begin

a1:=30000;

read(n);

for i:=1 to n do begin

read(a);

if (a<a1) and (a div 10 <10) and (a div 10 >1)and (a mod 2 = 0) then a1:=a;

end;

writeln(a1);

end.

var

b,x,c:real;

i,n,a:integer;

begin

x:=0;

b:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 7 = 0) or (a mod 3 = 0) then b:=b+a;

if (a mod 7 =0) or (a mod 3 = 0) then x:=x+1;

end;

c:=b/x;

writeln(c);

end.

var

a,b,x,i,n:integer;

begin

x:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 10 <>1) and (a mod 2 = 1) then x:=x+1;

end;

writeln(x);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

НА ПИТОНЕ С клавиатуры вводится предложение, в котором слова разделены пробелами. Определите, сколько слов в этом предложении заканчивается на букву "а"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

turaev-1098
tatianaavoronina66
Yanusik24
Жукова_Петрович1281
bolosolo77
kuznecovav3066
lanabogd
Feyruz90
joini09
vladimirkirv
ВладимировнаАлександр1421
danceplusru
format-l3364
muziumednogorsk
sedalex