Станиславович ыфвыв
?>

Напишите программу, вычисляющую значение функции у, если х>0, то у=10, если х<0, то у=-10

Информатика

Ответы

Elizavetaborisovna1992
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.
Васильева-Александрович

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

int a[20];

void solve(){

   ld sum = 0;

   for(auto i: a)

       sum += i;

   ld av = sum / 20;

   int res = 0;

   for(auto i: a)

       if(i < av)

           res++;

   cout << res;

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   for(int i = 0; i < 20; i++)

       cin >> a[i];

   solve();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, вычисляющую значение функции у, если х>0, то у=10, если х<0, то у=-10
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

seletan1
borodin
KosarinPotemkina1888
tkmandarin8376
bal4shovser16
О. Карпов1691
Рогова Ольга1156
razumeiko0790
vdk81816778
Шеина
галина
МАМОНОВА-андрей
tanyamurashova11352
Попов1946
Levinalx4938