julia3594265843
?>

Написать программу , которая n раз выводит на экран на одной строке имя и фамилию, на другой строке дату рождения. надо сравнить.

Информатика

Ответы

aerendzhenova5
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите имя и фамилию:');
  var g:=ReadlnString('Введите год рождения:');
  var n:=ReadInteger('Сколько раз повторить вывод?');
  loop n do Writeln(s,NewLine,g)
end.

Пример
Введите имя и фамилию: Иванов Сергей
Введите год рождения: 24.06.2001
Сколько раз повторить вывод? 3
Иванов Сергей
24.06.2001
Иванов Сергей
24.06.2001
Иванов Сергей
24.06.2001
annanudehead1426
Var first_name, data : string;i : byte; n : integer;
begin  write('Введи свое имя и фамилию: ');  readln(first_name);  write('Ведите свою дату ррождения: ');  readln(data);  readln(n);  for i := 1 to n do  write(first_name, ' ');  writeln(' ');  for i := 1 to n do  write(data, ' ');end.
jenn055
Все удачные наборы команд должны включать остановку на отметке 10 футов.
На отметку 1 фут робот может попасть с одной команды A;
на отметку 2 фута - с команд AA и B (всего 2 набора команд);
на отметку 3 фута - с команд AAA, AB, BA и C (4 набора).
Так как за одну команду робот может переместиться на 1, 2 или 3 фута, то для подсчета количества наборов команд, позволяющих роботу попасть на отметки N > 3, можно использовать формулу
K(N) = K(N-1)+K(N-2)+K(N-3).
K(4) = K(3)+K(2)+K(1) = 4+2+1 = 7
K(5) = K(4)+K(3)+K(2) = 7+4+2 = 13
K(6) = K(5)+K(4)+K(3) = 13+7+4 = 24
K(7) = K(6)+K(5)+K(4) = 24+13+7 = 44
K(8) = K(7)+K(6)+K(5) = 44+24+13 = 81
K(9) = K(8)+K(7)+K(6) = 81+44+24 = 149
K(10) = K(9)+K(8)+K(7) = 149+81+44 = 274
Так как вторая часть пути робота также имеет длину 10, то общее количество удачных наборов команд = 274*274= 75076
Nataliatkachenko1
Все удачные наборы команд должны включать остановку на отметке 11 футов.
На отметку 1 фут робот может попасть с одной команды A;
на отметку 2 фута - с команд AA и B (всего 2 набора команд);
на отметку 3 фута - с команд AAA, AB, BA и C (4 набора).
Так как за одну команду робот может переместиться на 1, 2 или 3 фута, то для подсчета количества наборов команд, позволяющих роботу попасть на отметки N > 3, можно использовать формулу
K(N) = K(N-1)+K(N-2)+K(N-3).
K(4) = K(3)+K(2)+K(1) = 4+2+1 = 7
K(5) = K(4)+K(3)+K(2) = 7+4+2 = 13
K(6) = K(5)+K(4)+K(3) = 13+7+4 = 24
K(7) = K(6)+K(5)+K(4) = 24+13+7 = 44
K(8) = K(7)+K(6)+K(5) = 44+24+13 = 81
K(9) = K(8)+K(7)+K(6) = 81+44+24 = 149
K(10) = K(9)+K(8)+K(7) = 149+81+44 = 274
K(11) = K(10)+K(9)+K(8) = 274+149+81 = 504
Так как вторая часть пути робота также имеет длину 11, то общее количество удачных наборов команд = 504*504 = 254016

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу , которая n раз выводит на экран на одной строке имя и фамилию, на другой строке дату рождения. надо сравнить.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anatolevich
Vladimirovna Dmitrieva
Lesnova_Kiseleva730
elegiy
Лоскутова
Марина_Мария
Stenenko
makashi28
ОвчинниковаТатьяна
hadzievamareta44
Оксана170
maksimforyou20
MaratФам
cheremetdiana
Vera-zero281