mrvasilev2012
?>

Напишите программу в Pascal, которая выводит наименьшую из четырех величин a, b, c, d.

Информатика

Ответы

milaudina

programm Z1;

var a, b, c,d:integer;

begin

writeln ('Введите четыре числа');

readln (a, b, c, d);

If a>b, a>c, a>d then

e:=a;

If b>a, b>c,b>d then

e:=b;

If c>a, c>b, c>d then

e:=c;

If d>a,d>b, d>c then

e:=d;

writeln ('Наибольшое число -',e);

end.

Golubitskaya378
VB.
Dim CountA As Integer
Dim CountB As Integer       
Dim x As Integer       
Dim a As Integer       
Dim b As Integer       
a = InputBox("Введите а")       
b = InputBox("Введите b")
        For x = 1 To Len(CStr(a))
            If CInt(Mid(CStr(a), x, 1)) Mod 2 = 0 Then CountA += 1
        Next
        For x = 1 To Len(CStr(b))
            If CInt(Mid(CStr(b), x, 1)) Mod 2 = 0 Then CountB += 1
'  c2fbefeeebede8eb3a20caf3eff0e8ffedeee220c42ec52e2028632920442d6d6f6e3535
        Next
        If CountA = CountB Then MsgBox("Количество четных цифр в двух числах равно")
        If CountA > CountB Then MsgBox("В первом числе количество четных цифр больше") Else MsgBox("Во втором числе количество четных цифр больше")
vakhitov100961

Для того чтобы работать с текстами на персональном компьютере или ноутбуке обычно используют специальные программные средства, которые принято называть текстовыми редакторами. Стоит отметить, что на сегодняшний день существует довольно большое разнообразие подобных программ, которые различаются своими возможностями и функциями, но наиболее популярным (по числу использования пользователями) остается MS Word 2010.

Вообще, основным назначением текстовых редакторов является создание текстовых файлов, редактирование уже готовых (или недоделанных) текстов с возможностью их на экране, изменять их формат, а также распечатывать на принтере. Кстати, следует уточнить, что Блокнот и другие аналогичные редакторы предназначены только для обработки несложных текстовых файлов, но никак не для работы с большим текстом.

Самым большим по своим возможностями до сих пор считается MS Word — текстовый редактор от компании Microsoft. В нем так же, как и во многих его аналогах можно:

форматировать символы, абзацы;

оформлять страницы;

"строить" указатели и оглавления;

включать в тесты графические объекты: фотографии, диаграммы, рисунки;

создавать таблицы, проверять правописание и т. д.

В современном мире существует уже много версий MS Word, наиболее популярными среди них считаются версии 2003, 2007, 2010 и 2013 года выпуска. Современный текстовый процессор Microsoft Word предназначен для создания, печати и модификации текстовых документов. Он предусматривает выполнение многих операций, как над текстовой, так и над графической или табличной информацией. Благодаря MS Word стало возможно быстро, а также с высоким качеством подготовить любой документ, причем от сложного до дает возможность осуществлять все традиционные операции над текстом (без исключений), которые предусмотрены в компьютерной современной технологии. С его можно:

модифицировать набор неформатированной цифровой и алфавитной информации;

форматировать символы, применяя множество шрифтов разных размеров и начертаний;

форматировать страницы (сюда также входят сноски, колонтитулы);

форматировать документ в целом (составлять оглавление, причем автоматическое, а также разные указатели);

подбирать синонимы, проверять правописание, использовать автоматический перенос слов.

В этой программе реализованы возможности новых технологий связывания, внедрения объектов, благодаря которым можно в документ включать таблицы, текстовые фрагменты и иллюстрации.

Это одна из первых общедоступных программ, с которой можно выполнять операции верстки, которые порой необходимы издательским профессиональным системам, а также с ее можно подготавливать полноценные оригинал-макеты для их последующего тиражирования в типографии.

Данная программа является уникальной коллекцией технологических оригинальных решений, благодаря которым нудная и кропотливая работа по отделке и редактированию текста превращается в увлекательное, а порой и успокаивающее занятие. В число таких решений входит система готовых стилей оформления и решений, изящные приемы по модификации и созданию таблиц, функции автозамены и автотекста, а также копирование формата, макроязык, пользовательские панели инструментов и многое другое.

Многие привыкли к другим же нравится оригинальный интерфейс версий 2007 или 2010 года выпуска. В основном же это дело привычки. Самое главное, что в современном мире это самый удобный, интуитивно-понятный и полезный инструмент для работы с текстовыми файлами

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в Pascal, которая выводит наименьшую из четырех величин a, b, c, d.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

germanleon
Александр Сергей
vallzh8328
kokukhin
lor005148
svetarakityanskaya
razumeiko0790
ekasatkina
Bogataya Vladimir318
Chuhnin195107364
Voronin-Albertovich
Shevtsov1818
Мусаев Игоревич371
Mbkozlov6
merzlikinairena