vitaldicky349
?>

Составить программу вычисления значений функции y = 2*x +1, на промежутке [-3; 6] с шагом 2 и ответить на во а) сколько раз выполнится цикл б) при каком значении х цикл выполнится последний раз в) при каком значении х цикл прервётся

Информатика

Ответы

Shpunt-86
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель.
Задача 1.
N=2^4=16 цветов.

Задача 2.
N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.

Задача 3.
65536 это 2^16⇒требуется 16 бит или 2 байта.

Задача 4.
1. Узнаем общее количество пикселей 1280*1024=1310720
2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб
ответ: 5 Мб
YekaterinaAbinskov

В n будем хранить количество чисел, которые ещё нужно вывести. a и b - предыдущее и текущее числа Фибоначчи. По определению, следующее число Фибоначчи равно сумме двух предыдущих, так что новое значение b будет a + b. Чтобы не заводить новую временную переменную, новое значение a можно будет найти, вычитая из нового b старое a, получится (a + b) - a = b.

Код процедуры:

procedure print_fib(n: integer);

var a, b, t: integer;

begin

   a := 0;

   b := 1;

   while n > 0 do

   begin

       write(b, ' ');

       b := a + b;

       a := b - a;

       n := n - 1;

   end;

end;

Пример основной программы:

begin

   print_fib(10)

end.

Вывод:

1 1 2 3 5 8 13 21 34 55

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления значений функции y = 2*x +1, на промежутке [-3; 6] с шагом 2 и ответить на во а) сколько раз выполнится цикл б) при каком значении х цикл выполнится последний раз в) при каком значении х цикл прервётся
Ваше имя (никнейм)*
Email*
Комментарий*