ИвановнаВладимир1832
?>

7) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она: var x, y: real; begin readln(x, y); if x <= 1 then if y <= 1 then if x*x + y*y <= 1 then write('принадлежит') else write('не принадлежит'); end. ​

Информатика

Ответы

kamalfayed229
1.ответ: скорее всего C(b и d идентичны) 2.if условие then begin операторы; end else begin операторы; end: 3. a) if x:=y then begin x:=0; y:=0; end else writeln(z); (Перед else никогда не ставиться запятая; после и перед then тем более; если нужно указать несколько операторов, то в зависимости от условия задачи устанавливаем begin и end) b) Некорректная задача. Где блок-схема? 4. var a,b,c:integer;
begin
readln(a,b,c);
if a mod 2=1 then writeln(a*a*a);
if b mod 2=1 then writeln(b*b*b);
if c mod 2=1 then writeln(c*c*c);
end.
5. Опять же некорректная задача. В каком смысле нарисовать?

вас чисто сердечно мне(( 1) выберите из предложенных полные записи оператора if: a) if x> y then
qadjiyevaaynura
Примеры материальных систем: дерево, здание, человек, планета Земля, Солнечная система.
Примеры нематериальных систем: человеческий язык, математика.
Пример смешанных систем – школа, университет. Она включает в себя как материальные части (школьное здание, оборудование, тетради и пр.) , так и нематериальные (учебные планы, программы, расписание уроков) .
Каждая система обладает следующими свойствами:

Функция (цель, назначение) системы;
Взаимодействие системы с окружающей средой;
Состав системы;
Структура системы;
Системный эффект.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

7) Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист торопился и написал программу неправильно. Вот она: var x, y: real; begin readln(x, y); if x <= 1 then if y <= 1 then if x*x + y*y <= 1 then write('принадлежит') else write('не принадлежит'); end. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetegal
saa002
Маринина_Елена
titancore
Yelizaveta1848
Astrians
Less2014
bondarev05071962
puchkovajulia
Nertman45
evada2
M10M11M12
saveskul84
skvik71672
klimenokvapeshop1408