osandulyak
?>

Напишите программу на языке JavaScript, которая будет рассчитывать потенциальную энергию по формуле: Eп=mgh. Данные должны вводиться заранее с клавиатуры. Необходимо учитывать, что g – ускорение свободного падения (постоянная величина В случае не ввода данных или при вводе не числовых значений, должны выводиться сообщения об ошибке. Результат вывести на зеленом фоне с выравниванием по левому краю. Добавить кнопку, которая будет перезапускать программу и ссылку, которая будет изменять цвет фона на красный.

Информатика

Ответы

osechkinandrejj
Представим число 108.5 в нормализованном экспоненциальном виде:
1.085*102 = 1.085*exp102
Число 1.085*exp102 состоит из двух частей: мантиссы M=1.085 и экспоненты exp10=2
Если мантисса находится в диапазоне 1 ≤ M < 10, то число считается нормализованным.

Представим число 24.625 в нормализованном экспоненциальном виде:
2.4625*101 = 2.4625*exp101
Число 2.4625*exp101 состоит из двух частей: мантиссы M=2.4625 и экспоненты exp10=1
Если мантисса находится в диапазоне 1 ≤ M < 10, то число считается нормализованным.

Представим число 12.125 в нормализованном экспоненциальном виде:
1.2125*101 = 1.2125*exp101
Число 1.2125*exp101 состоит из двух частей: мантиссы M=1.2125 и экспоненты exp10=1
Если мантисса находится в диапазоне 1 ≤ M < 10, то число считается нормализованным.

Представим число -86.25 в нормализованном экспоненциальном виде:
-8.625*101 = -8.625*exp101
Число -8.625*exp101 состоит из двух частей: мантиссы M=-8.625 и экспоненты exp10=1
Если мантисса находится в диапазоне 1 ≤ M < 10, то число считается нормализованным.

Код числа бывает прямой, обратный и дополнительный.
Коновалова
1)
#include <stdio.h>
 
int main() {
 int a = -1;
 while(a != 0)
    scanf("%d", &a);
}
2)
#include <stdio.h>
#include <math.h>
 
int main() {
 int a;
 scanf("%d", &a);
 int prime = 1;
 for(int i = 2; i <= sqrt(a)+1; i++)
    if(a%i == 0) {
      prime = 0;
      break;
    } if((prime == 0 && a != 2) || a == 1) printf("NO\n");
 else printf("YES\n");
}
3)
#include <stdio.h>

int main() {
 int a[5];
 for(int i = 0; i < 5; i++)
   scanf("%d", &a[i]);
 for(int i = 0; i < 5; i++)
   printf("%d ", a[i]);
 printf("\n");
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке JavaScript, которая будет рассчитывать потенциальную энергию по формуле: Eп=mgh. Данные должны вводиться заранее с клавиатуры. Необходимо учитывать, что g – ускорение свободного падения (постоянная величина В случае не ввода данных или при вводе не числовых значений, должны выводиться сообщения об ошибке. Результат вывести на зеленом фоне с выравниванием по левому краю. Добавить кнопку, которая будет перезапускать программу и ссылку, которая будет изменять цвет фона на красный.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilyanedelev
egorova90356684858370
Vkois56
tatyanaryzhkova
iuv61
Nastyaches4
serebrennikova99
rgmarket
markitandl
Джамалутдинова Докучаев
VadimovichSvetlana622
lemoh
xeniagolovitinskaya4546
Anatolevna1703
koeman