Пример работы:
program SumSeq;
{$APPTYPE CONSOLE}
uses
SysUtils;
//const m:Integer ;
var
i, j, m, s:Integer;
n: array of Integer;
begin
s:=0;
Writeln(m);
Writeln('vvedite m');
Readln(m);
SetLength(n,m);
for i:=0 to m do
begin
j:=Random(10);
if j<5
then n[i]:=-1*j
else n[i]:=j;
write(n[i], ' ')
end;
Writeln;
Writeln('To continue push >>ENTER');
Readln;
for i:=0 to m do
begin
if n[i]<0
then s:=s+sqr(n[i])
end;
writeln('s=',s);
readln
{ TODO -oUser -cConsole Main : Insert code here }
end.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая вводит массив из 6 столбцов и 4 строк, в котором значение каждого элемента соответствует номеру столбца. Также нужно вывести на экран полученный массив, числа в строке должны быть разделены запятой с пробелом, а в конце строки никаких знаков быть не должно. (паскаль)
--- PascalABC.NET 3.6.2 ---
const row = 4;
const col = 6;
procedure MatrixPrintln<T>(Matrix: Array[,] of T; LineSep: string);
begin
foreach var mRow in Matrix.Rows do begin
string.Join(LineSep, mRow).Println;
end;
end;
begin
var Matrix := new integer[row,col];
for var i := 0 to row-1 do begin
for var k := 0 to col-1 do begin
Matrix[i,k] := k+1;
end;
end;
matrixPrintln(Matrix, ', ');
end.