turovskaya69
?>

Пермационные технологии, экзамен прос 1 определите значение переменной "с" после выполнения следующего фрагмента программы: int a = 5; кa нет ответа пл. 1.00 a = a +6; Отметить int b = -a; прос int c = -а-2" b; Выберите один или несколько ответов: 1. 0 2. -11 3. 11 4. 10 Предыдущая страница

Информатика

Ответы

alvas12828646

1 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

case a of

1:writeln('Зима');

2:writeln('Зима');

3:writeln('Весна');

4:writeln('Весна');

5:writeln('Весна');

6:writeln('Лето');

7:writeln('Лето');

8:writeln('Лето');

9:writeln('Осень');

10:writeln('Осень');

11:writeln('Осень');

12:writeln('Зима');

end;

end.

2 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

if (a=12) or (a=1) or (a=2) then writeln('зима');

if (a=3) or (a=4) or (a=5) then writeln('весна');

if (a=6) or (a=7) or (a=8) then writeln('лето');

if (a=9) or (a=10) or (a=11) then writeln('осень');

end.

Bezzubova_Stepanov1355

Известны два расстояния: одно в километрах, другое—в футах(1 фут=0,45 м). Какое из расстояний меньше?

Program ss;
uses crt;
var
a,b,c,s,s1: integer;
Begin
clrscr;
Writeln('Введите расстояние в километрах:');
readln(a);
Writeln('Введите расстояние в футах');
readln(b);
writeln('Введите размер одного фута в метрах');
s:=a*1000;
s1:=c*b;

if s>s1 then
begin
write('Расстояние в футах меньше чем в км');
end
else
writeln('Расстояние в км меньше чем в футах');
writeln(' Программа завершена нажмите ');
readln;
End.

Известны две скорости: одна в километрах в час, другая—в метрах в секунду. Какая из скоростей больше?
program EvGeN;
var
kilom: real;
metr: real;
begin
kilom := metr * 1.6;
write('Введите скорость в км\ч: ');
readln(kilom);
write('Введите скорость в м\с: ');
readln(metr);
if kilom < metr then write('скорость в км\ч больше');
if kilom > metr then write('скорость в км\ч меньше');
if kilom = metr then write('скорость в км\ч равна скорости в м\ч');
end.

Даны радиус круга и сторона квадрата. У какой фигуры площадь больше
Program ploshcad;
var R,D,skr,skv:extended;
Begin
write('Введите радиус круга: '); readln®;
write('Введите сторону квадрата'); readln(D);
skr:=Pi*sqr®;
writeln('Площадь круга: ',skr:10:5);
skv:=sqr(D);
writeln('Площадь квадрата: ',skv:10:5);
If skr=skv then
writeln('Площади равный');
If skr>skv then
writeln('Площадь круга больше');
If skv<skr then writeln('Площадь квадрата больше');
readln;
End.

 Известны площади круга и квадрата. Определить:
a) Уместится ли круг в квадрате?
b) Уместится ли квадрат в круге?

Program prim;
Var a,r,s1,s2:real;
Begin
Write('введите площадь круга и квадрата');
Readln(s1, s2);
A:=sqrt(s2);
R:=sqrt(s/3.14);
If (r<a/2) then writeln (' круг уместится в квадрате')
Else writeln (' круг не уместится в квадрате');
If (a*sqrt(2))>(4*r) then writeln ('квадрат уместится в круге')
Else Writeln('квадрат не уместится в круге');
Readln
End.

Даны объёмы и массы двух тел из разных материалов. Материал какого из тел имеет большую плотность.
var v1,v2,m1,m2,p1,p2: real;
begin
writeln('Введите объем и массу первого тела');
readln(v1,m1);
writeln('Введите объем и массу второго тела');
readln(v2,m2);
p1:=v1/m1;
p2:=v2/m2;
if p1>p2 then begin
writeln('Плотность первого тела больше');
end;
if p1<p2 then begin
writeln('Плотность второго тела больше');
end
else if p1=p2 then begin
writeln('Плотности тел равны');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Пермационные технологии, экзамен прос 1 определите значение переменной "с" после выполнения следующего фрагмента программы: int a = 5; кa нет ответа пл. 1.00 a = a +6; Отметить int b = -a; прос int c = -а-2" b; Выберите один или несколько ответов: 1. 0 2. -11 3. 11 4. 10 Предыдущая страница
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

s45983765471717
znaberd786
edvlwork15
Chutaeva381
langprint
abuzik
Суханова1532
Zhanibekrva Kandaurova
Aleksandr556
Vladimir
djevgen
NIKOLAEVNA
kyzua2475
airon-082054
Bi-1704