gelena03
?>

Язык программирования - Python Шахматный король ходит по горизонтали, вертикали и диагонали, но только на одну клетку. Даны две различные клетки шахматной доски, определите, может ли король попасть с первой клетки на вторую одним ходом. Входные данные Входной файл состоит из двух строк — координат первой и второй клетки в шахматной нотации. Как известно, в шахматной нотации горизонтальные строки обозначаются цифрами от 1 до 8, считая от расположения белых фигур, стоящих внизу доски, а вертикальные столбцы — буквами латинского алфавита: a, b, c, d, e, f, g, h. Выходные данные Программа должна вывести YES, если из первой клетки ходом короля можно попасть во вторую, или NO в противном случае. Примеры Ввод a1 a1 a1 c1 Вывод: YES NO

Информатика

Ответы

oksana-popova

На скриншоте ====================


Язык программирования - Python Шахматный король ходит по горизонтали, вертикали и диагонали, но толь
rusinfopro
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13
nuralievelsh

 Program SumAndMul;

Uses Crt;

var a:array[1..10] of real;

       i:integer;   

 

       sum,mul:longint;

begin

     clrscr;

     for i:=1 to 10 do

            begin

                 write('Введите -', i,' число:'  );

                  readln(a[i]);

             end;

 

 

sum:=0;mul:=1;

for i:=1 to 10 do

            begin

                if (a[i]>0) then sum:=sum+a[i];

                if (a[i]<0 )  then mul:=mul*a[i];

             end;    

 writeln('Сумма положительных элементов: ',sum);

 writeln('Произведение отрицательных элементов: ',mul);  

   readkey;

 

end.

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык программирования - Python Шахматный король ходит по горизонтали, вертикали и диагонали, но только на одну клетку. Даны две различные клетки шахматной доски, определите, может ли король попасть с первой клетки на вторую одним ходом. Входные данные Входной файл состоит из двух строк — координат первой и второй клетки в шахматной нотации. Как известно, в шахматной нотации горизонтальные строки обозначаются цифрами от 1 до 8, считая от расположения белых фигур, стоящих внизу доски, а вертикальные столбцы — буквами латинского алфавита: a, b, c, d, e, f, g, h. Выходные данные Программа должна вывести YES, если из первой клетки ходом короля можно попасть во вторую, или NO в противном случае. Примеры Ввод a1 a1 a1 c1 Вывод: YES NO
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iptsr4968
milkamilka1998
Валерьевич Николаевич1364
ski89439
kmr495270
akinin95
Артем Уберт
Кочугурова
girra
manuchar-formen2
zotti
ВалентиновичСуриковна1104
vadim1140
iivanovar-da
Зинина-Олесия