Иванина
?>

Напишите программу, которая в качестве аргумента принимает имя файла (не указан файл или указан несуществующий — ошибка) и выводит его содержимое на экран. В добавок, программа может принимать дополнительные агрументы: «--count» для вывода кол-ва строк в конце сообщения, «--num» для вывода порядкового номера с пробелом в начале каждой строки, «--sort» для сортировки строк в алфавитном порядке перед выводом. Пусть файл text1.txt содержит строки: Houston we have a problemПример 1 Ввод Вывод python3 solution.py --num text1.txt 0 Houston 1 we have 2 a problem Пример 2 Ввод Вывод python3 solution.py --count --sort text1.txt Houston a problem we have rows count: 3 Пример 3 Ввод Вывод python3 solution.py --count --sort textX.txt ERROR Примечания Необходимо использовать s y s . a r g v . При наличии ошибки необходимо вывести слово ERROR python

Информатика

Ответы

Petrovich

--num» для вывода порядкового номера с пробелом в начале каждой строки,

«--sort» для сортировки строк в алфавитном порядке перед выводом.

Пусть файл text1.txt содержит строки:

Houston

we have

a problemПример

slavutich-plus2
A) в 2:
273/2=136(1)
136/2=68(0)
68/2=34(0)
34/2=17(0)
17/2=8(1)
8/2=4(0)
4/2=2(0)
2/2=(1)
100010001
в 8:
273/8=34(1)
34/8=4(2)
4/8=(4)
421
в 16:
273/16=17(1)
17/16=1(1)
111
б) в 2:
661/2=330(1)
330/2=165(0)
165/2=82(1)
82/2=41(0)
41/2=20(1)
20/2=10(0)
10/2=5(0)
5/2=2(1)
2/2=1(0)
1/2=(1)
1010010101
в 8:
661/8=82(5)
82/8=10(2)
10/8=1(2)
1/8=(1)
1225
в 16:
661/16=41(5)
41/16=2(9)
2/16=(2)
295
в) в 2:
156/2=78(0)
78/2=39(0)
39/2=19(1)
19/2=9(1)
9/2=4(1)
4/2=2(0)
2/2=1(0)
1/2=(1)
2*0,25=0,5 (0)
2*0,5=1 (1)
10011100,01
в 8:
156/8=19(4)
19/8=2(3)
2/8=(2)
0,25*8=2 (2)
234,2
в 16:
156/16=9(12)
9/16=(9)
0,25*16=4 (4)
9C,4
г) в 2:
797/2=398(1)
398/2=199(0)
199/2=99(1)
99/2=49(1)
49/2=24(1)
24/2=12(0)
12/2=6(0)
6/2=3(0)
3/2=1(1)
1/2=(1)
0,5*2=1 (1)
1100011101,1
в 8:
797/8=99(5)
99/8=12(3)
12/8=1(4)
1/8=(1)
0,5*8=4 (4)
1435,4
в 16:
797/16=49(13)
49/16=3(1)
3/16=(3)
16*0,5=8 (8)
31D,8
nusupova
1) Не понятно задание, в комментах допишу, как только пойму.
2)var t,c:array [1..10] of integer;
    i,sum:integer;
begin
for i:=1 to 10 do begin
   t[i]:=random(20+i);
   c[i]:=random(20000+i);
end;
for i:=1 to 10 do begin
   sum:=sum+t[i]*c[i];
end;
for i:=1 to 10 do begin
   writeln('Количество товара ',i,' вида ',t[i],'  Стоимость товара ',i,' вида ', c[i]);
end;
writeln('Общая сумма ',sum);
end.
3) Мы опишем его так
    ves: array [1..31] of real;
4)
var sum,x:real;
    n,i:integer;
begin
read(n);
for i:=1 to n do begin
   read(x);
   sum:=sum+x;
   end;
writeln(sum/n);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в качестве аргумента принимает имя файла (не указан файл или указан несуществующий — ошибка) и выводит его содержимое на экран. В добавок, программа может принимать дополнительные агрументы: «--count» для вывода кол-ва строк в конце сообщения, «--num» для вывода порядкового номера с пробелом в начале каждой строки, «--sort» для сортировки строк в алфавитном порядке перед выводом. Пусть файл text1.txt содержит строки: Houston we have a problemПример 1 Ввод Вывод python3 solution.py --num text1.txt 0 Houston 1 we have 2 a problem Пример 2 Ввод Вывод python3 solution.py --count --sort text1.txt Houston a problem we have rows count: 3 Пример 3 Ввод Вывод python3 solution.py --count --sort textX.txt ERROR Примечания Необходимо использовать s y s . a r g v . При наличии ошибки необходимо вывести слово ERROR python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iskypka
MIKhAILOVNAAnton
Varezka86179
МАМОНОВА-андрей
karavan85450
Yekaterina_Popova1413
kartyshkinaaa
Tyukalova
Павел_Перелыгин
karpovaveronika196
N-odes-art-school410
alex091177443
Никита
Vitalevich
heodbxbbshe