lebedevevgen
?>

Напечатать все четырёхзначные натуральные числа, в записи которых есть одинаковые цифры. Составить программу.

Информатика

Ответы

ilds88

100, 200, 300, 400, 500, 600, 700, 800, 900

Объяснение:

Во всех числах два нуля

silviya
1111 1222 1122 1112 2222 2111 2211 2221 1333 1133 1113 3333 3331 3311 3111 3332 3322 3222 2223 2233 2333 2323 3232 1212 2121 и тд
Lenok33lenok89

/*Решение с обобщения формула Брахмагупты для произвольного четырехугольника. Функция perimeter(double x[], double y[]) возвращает значение периметра, функция area(double x[], double y[]) возвращает значение площади, пример использования и реализация приведены ниже. */

#include <iostream>

#include <math.h>

double perimeter(double x[], double y[]);

double area(double x[], double y[]);

int main()

{

   double x[4], y[4];

   std::cout << "Quadrangle ABCD\n";

   for (auto i = 0; i < 4; i++)

   {

       std::cout << "Input coordinates of point " << char(i + 'A') << ": ";

       std::cin >> x[i] >> y[i];

   }

   std::cout << perimeter(x, y) << " " << area(x, y);

   

   return 0;

}

double perimeter(double x[], double y[])

{

   double a[4], p = 0;

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   return p;

}

double area(double x[], double y[])

{

   double a[4], p = 0, s = 1, d[2];

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   for (auto i = 0; i < 4; i++)

   {

       s *= (p / 2- a[i]);

   }

   for (auto i = 0; i < 2; i++)

   {

       d[i] = sqrt((x[i]-x[i + 2]) * (x[i]-x[i + 2]) + (y[i]-y[i + 2]) * (y[i]-y[i + 2]));

   }

   s -= (a[0] * a[2] + a[1] * a[3] + d[0] * d[1]) * (a[0] * a[2] + a[1] * a[3] - d[0] * d[1]) / 4;

   s = sqrt(s);

   return s;

}

artmasterstyle
Var A,B: array [1..10,1..10] of integer; 
i, j, n: integer;
begin
Randomize;writeln('Введите размерность n');readln(n);writeln('Матрица А');
for i:=1 to n do begin
for j:=1 to n do  begin
A[i,j]:= random(10)+1;write(A[i,j]:3);end;writeln;end;
writeln('Матрица B');
for i:=1 to n do begin
for j:=1 to n do  begin
B[i,j]:= random(10)+2;write(B[i,j]:3);end;writeln;end;
writeln('ответ: матрица AB');
for i:=1 to n do
for j:=1 to n do  begin C[i,j]:=(A[i,j]*B[i,j]);end;writeln;
for i:=1 to n do  begin
for j:=1 to n do  begin
write(C[i,j]:3);end; writeln;end;
writeln('ответ :матрица ВА');
for i:=1 to n do
for j:=1 to n do begin D[i,j]:=(B[i,j]*A[i,j]);end; 
for i:=1 to n do begin
for j:=1 to n do begin
write(D[i,j]:3);end; writeln;end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напечатать все четырёхзначные натуральные числа, в записи которых есть одинаковые цифры. Составить программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hotel-info
александр496
rendikalogistic
kyrtlab39
opel81
mulyugina365
ren7869
verynzik66525
baron
Obukhov-Buriko
Каныбек698
dima0218687
Державина
Татьяна1252
Iprokopova81
▲