Nv-444
?>

Написать программу Pascal abc В шкатулке хранится разноцветный бисер (или бусины Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета. Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета. Входные данные Входной файл INPUT.TXT содержит одно натуральное число N - количество цветов бусин (1 ≤ N ≤ 109). Выходные данные В выходной файл OUTPUT.TXT выведите ответ на поставленную задачу.

Информатика

Ответы

lescha-77766

var N: integer;

var f: text;  

begin

assign(f,'C:\1\INPUT.TXT');

reset(f);

read(f,N);

close(f);

assign(f,'C:\1\INPUT.TXT');

rewrite(f);

write(f,N+1);

close(f);

end.

antilopa001
Var i,ne,ch,n:integer;
      a:array of integer; //объявление динамического массива
begin
write('Введите длину массива :');
readln(n);
randomize;
a:= new integer[n+1];// установка размера (n+1) динамического массива
for i:=1 to n do
      begin
      a[i]:=random(80)+20;
      write(a[i],' ');//Вывод на экран полученного массива                         
      if odd(a[i]) then inc(ne);// odd() - функция,определяющая нечетность числа.Возвращает значение True, если число нечетное
      end;                      //inc() - функция инкремент - увелечения на 1.
ch:= n-ne;
writeln;
writeln('Нечетные=',Ne);
writeln('Четные=',Ch);
end.
nadejdashin508
Последний день перед Рождеством Зимняя, ясная ночь наступила. Глянули звезды. Месяц величаво поднялся на небо посветить добрым людям и всему миру, чтобы всем было весело колядовать... (Н. В. Гоголь. Вечера на хуторе близ Диканьки)

239 символів включаючи пробіли між словами, знаки пунктуації і букви. Якщо в 8 бітному кодуванню то кожен символ кодується 8 бітами(або 1 байтом)
239*8=1912біт=239байт (щоб перейти від біт до байт треба просто поділити на 8, тому що 1 байт має 8 біт)

Якщо в 16 бітному(або 2 байтовому) то
239*16=3824біт=478байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу Pascal abc В шкатулке хранится разноцветный бисер (или бусины Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета. Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета. Входные данные Входной файл INPUT.TXT содержит одно натуральное число N - количество цветов бусин (1 ≤ N ≤ 109). Выходные данные В выходной файл OUTPUT.TXT выведите ответ на поставленную задачу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kuharhuks
strager338
triumfmodern
AOS2015
bei07
Natacha3636672
barg562
rusplatok
Valentinovna
ГегамБукреев830
avdoyan6621
smirnovaL1286
yulyaderesh
dokmak140652
delfa-r6289