guujuu
?>

Вы решили поехать в поход и Вам необходимо положить в рюкзак необходимые вещи: фонарик и компас, палатку, аптечку, зажигалку, воду и еду, предметы личной гигиены. Напишите программу на Python для реализации выбора данных вещей. При нажатии на виджет Checkbutton, его фон должен окраситься в светло-зелёный цвет и стать недоступным

Информатика

Ответы

alekseysokolov29816

В массиве, содержащем положительные и отрицательные целые числа, вычислить сумму четных положительных элементов.

Максимальный из элементов массива с четными индексами

В массиве найти максимальный элемент с четным индексом.

Другая формулировка задачи: среди элементов массива с четными индексами, найти тот, который имеет максимальное значение.

Элементы массива, которые меньше среднего арифметического

Найти в массиве те элементы, значение которых меньше среднего арифметического, взятого от всех элементов массива.

Найти два наименьших (минимальных) элемента массива

В одномерном массиве целых чисел определить два наименьших элемента. Они могут быть как равны между собой (оба являться минимальными), так и различаться.

Сжать массив, удалив элементы, принадлежащие интервалу

Сжать массив, удалив из него все элементы, величина которых находится в интервале [а, b]. Освободившиеся в конце массива элементы заполнить нулями.

Сумма модулей элементов массива, расположенных после первого отрицательного

Вычислить сумму модулей элементов массива, расположенных после первого отрицательного элемента.

Например, в массиве [5, 3, -1, 8, 0, -6, 1] первый отрицательный элемент является третьим по счету, а сумма модулей стоящих после него элементов массива будет составлять 8 + 0 + 6 + 1 = 15.

Номер минимального по модулю элемента массива

Найти номер минимального по модулю элемента массива.

Например, в массиве [10, -3, -5, 2, 5] минимальным по модулю элементом является число 2. Его номер 4 (в языках, в которых индексация массивов начинается с нуля, его индекс будет равен 3).

Сумма цифр массива

Найти сумму всех цифр целочисленного массива. Например, если дан массив [12, 104, 81], то сумма всех его цифр будет равна 1 + 2 + 1 + 0 + 4 + 8 + 1 = 17.

Найти сумму элементов между минимальным и максимальным элементами массива

В одномерном массиве найти сумму элементов, находящихся между минимальным и максимальным элементами. Сами минимальный и максимальный элементы в сумму не включать.

Среднее арифметическое положительных элементов массива

Найти среднее арифметическое положительных элементов линейного массива.

Максимальный отрицательный элемент массива

В массиве найти максимальный отрицательный элемент. Вывести на экран его значение и позицию в массиве.

Число, чаще всего встречающееся в массиве

Определить, какое число в массиве встречается чаще всего.

Поменять местами минимальный и максимальный элементы

В массиве случайных целых чисел поменять местами минимальный и максимальный элементы.

krispel9
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вы решили поехать в поход и Вам необходимо положить в рюкзак необходимые вещи: фонарик и компас, палатку, аптечку, зажигалку, воду и еду, предметы личной гигиены. Напишите программу на Python для реализации выбора данных вещей. При нажатии на виджет Checkbutton, его фон должен окраситься в светло-зелёный цвет и стать недоступным
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

asparinapti39
shugayzhanna6
Neveselova
info2990
xobby18
cheberyako2013
borisowaew
Obukhov-Buriko
AHO436
Смирнов-Оськина
Seropyan-Elena1944
Александрович
nzagrebin363
Sukharev-Achkasov
Viktoriya405