Вершинина1161
?>

Представьте, что робот находится на поле 150×150 см. Напротив него, на разном расстоянии, находятся 3 препятствия. Напишите программу, благодаря которой робот вычислит расстояние до каждого из объектов, сравнит полученные данные и доедет до ближайшего объекта. На следующем этапе он должен расстояние до двух оставшихся объектов и снова доехать до ближайшего, а после этого – до самого дальнего. все делается через LEGO MINDSTORM EDUCATION

Информатика

Ответы

makarov021106

#include <iostream>

#include <ctime>

#include <algorithm>

signed main() {

 

setlocale(LC_ALL, "Rus");

srand(time(NULL));

 

int n;

std::cout << "Размер массива: ";

std::cin >> n;

int* arr = new int[n];

std::cout << "Исходный массив: ";

for (int i = 0; i < n; i++) {

 arr[i] = rand() % 10;

 std::cout << arr[i] << " ";

}

for (int i = 0; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (arr[j] > arr[j + 1])

   std::swap(arr[j], arr[j + 1]);

 }

}

std::cout << std::endl << arr[n - 1] + arr[n - 2];

return 0;

}

M10M11M12

#include <iostream>

#include <string>

#define SIZE 3

/*

Структура содержит 3 поля, фамилия и оценки имеют тип string, поле с годом рождения имеет тип int;

Также имеется метод, с которого происходит ввод информации.

*/

struct student {

std::string surname;

int birthYear;

std::string marks;

void InputInfo() {

 std::cout << "Фамилия студента: ";

 getline(std::cin, surname);

 std::cout << "\nГод рождения студента: ";

 std::cin >> birthYear;

 std::cin.ignore();

 std::cout << "\nОценки студента: (через пробел): ";

 getline(std::cin, marks);

}

};

/*

В основной функции мы создаем массив структур "group" размера SIZE (SIZE объявили выше)

Затем находим сумму возрастов и делим ее на размер массива структур

*/

signed main() {

setlocale(LC_ALL, "Rus");

student group[SIZE];

int _sumAge = 0;

for (int i = 0; i < SIZE; ++i) {

 group[i].InputInfo();

 _sumAge += 2022 - group[i].birthYear;

}

std::cout << "\nСредний возраст студентов в группе:" << _sumAge / SIZE;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Представьте, что робот находится на поле 150×150 см. Напротив него, на разном расстоянии, находятся 3 препятствия. Напишите программу, благодаря которой робот вычислит расстояние до каждого из объектов, сравнит полученные данные и доедет до ближайшего объекта. На следующем этапе он должен расстояние до двух оставшихся объектов и снова доехать до ближайшего, а после этого – до самого дальнего. все делается через LEGO MINDSTORM EDUCATION
Ваше имя (никнейм)*
Email*
Комментарий*