sergeykvik13
?>

СОСТАВИТЬ БЛОК СХЕМЫ К ЗАДАЧАМ. 1.Составьте программу, которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения. 2.Задано натуральное число a. Является ли оно чётным? 3.Задано натуральное число a. Является ли оно кратным 9?

Информатика

Ответы

mzia-mzia-60682

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

AHO436
P.S.

Тернарная операция в C++ - это выражение вида (b ? x : y) (где b - логическое выражение, а x и y - одного типа). Она вернёт x, если выражение b истинно, и y, если b ложно.


Решение

В приложении расписаны координаты некоторых клеток, а также помечены точками те, которые по цвету отличаются от не помеченных. Если поискать, что у них общего, можно обнаружить, что у "невыколотых" клеток сумма координат по горизонтали и вертикали - чётная. Это "свойство" и используем для определения цвета клетки.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

 int x1, y1, x2, y2;

 cin >> x1 >> y1 >> x2 >> y2;

 cout << ((x1 + y1) % 2 == (x2 + y2) % 2 ? "YES" : "NO") << endl;

 return 0;

}



На с++ с тернарной операцией поле шахматной доски определяется парой натуральных чисел, каждое из ко

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

СОСТАВИТЬ БЛОК СХЕМЫ К ЗАДАЧАМ. 1.Составьте программу, которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения. 2.Задано натуральное число a. Является ли оно чётным? 3.Задано натуральное число a. Является ли оно кратным 9?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

msangelika1010
mila-vsv
Valerevna-Vardan
darialyagina
OOO&quot;Kiprei&quot;_Aleksandr1938
danya1509379
yda659
Dom540703174
Pautova1119
docvet4
kireevatatiana
ielienakozlova696
osechkinandrejj
Голубева1440
info6