type
Str = record
fio: string;
h: byte;
end;
var
base: array of Str;
i,sum,n,err:integer;
begin
write('Число учеников: '); readln(n);
setlength(base,n);
sum:=0;
writeln('Введите фамилию и рост через "space": ');
for i:=0 to n-1 do
begin
write(i+1:4,'. ');
readln(base[i].fio);
val(copy(base[i].fio,
pos(' ',base[i].fio)+1,
length(base[i].fio)-pos(' ',base[i].fio)),
base[i].h,
err);
delete(base[i].fio,
pos(' ',base[i].fio),
length(base[i].fio));
sum:=sum+base[i].h;
end;
writeln('Средний рост: ',sum/n:4:1);
for i:=0 to n-1 do
if base[i].h<sum/n then
writeln(base[i]);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Вариант 3 1) Составить программу, которая четные числа удваивает, а к нечетным числам прибавляет 3. 2) Составить программу, которая спрашивает рост человека и, если рост удовлетворяет условию: 187см ≥ рост ≤ 205см сообщает “Поздравляем, Вы приняты в секцию баскетбола”, а в противном случае – “К сожалению, мы не можем Вас принять в баскетбольную секцию”.. 3) Составить программу, которая запрашивает ввод трех значений температуры и проверяет, есть ли среди них температура таяния льда? 4) В ЭВМ поступают результаты соревнований по плаванию для 3-х спортсменов. Составьте программу, которая выбирает наихудший результат и выводит его на экран с сообщением, что это результат достоин третьего места. 5) Составьте программу, которая по введенному вами В – количество , печатает фразу «Я набрал В », причем согласовывает окончание слова « » с числом В. Количество может быть любым целым числом: 1, 3, 34, 127 и т.д. Окончание фразы определяется значением последней цифры (не всегда!
1. Во втором письме содержится меньшее количество информации на 5 500 бит
2. 256 секунд
Объяснение:
1.
I = К * i, где
I - информационный объём письма (документа)
К - количество символов в письме (документе)
i - информационный вес символа (количество бит, которым кодируется 1 символ)
N = 2^i, где
N - мощность алфавита (количество символов в алфавите)
i - информационный вес символа (количество бит, которым кодируется 1 символ)
Дано:
K₁ = 25 строк * 50 символов = 1 250 символов
N₁ = 256 символа
K₂ = 2 страницы * 15 строк * 30 символов = 900 символов
N₂ = 32 символа
Найти:
I ₁ - I₂
256 = 2^i ₁
i₁ = 8 бит
32 = 2^i ₂
i₂ = 5 бит
I₁ = 1 250 * 8 = 10 000 бит
I₂ = 900 * 5 = 4 500 бит
I ₁ - I₂ = 10 000 - 4 500 = 5 500 бит
2.
I = К * i, где
I - информационный объём сообщения (документа)
К - количество символов в сообщении (документе)
i - информационный вес символа (количество бит, которым кодируется 1 символ)
К = V * t, где
K - количество символов в сообщении (документе)
V - скорость печати принтера
t - время печати принтера
Дано:
V = 1 024 символа/с
I = 256 Кбайт = 262 144 байт
i = 1 байт (предположительно)
Найти:
t
I = К * i
К = I / i
К = 262 144 / 1 = 262 144 символов
К = V * t
t = К / V
t = 262 144 / 1 024 = 256 секунд
1 Кбайт = 1024 байт