printdecor
?>

Устное или ребусное путешествие к одному из слов алгоритма, программы, вещателя, компилятора, переводчика

Информатика

Ответы

Vova220

ответ: Программа рабочая, проверена.

Program zadacha;

var  

 a: array [1..50] of integer; // размерность массива = 50

 i,k: integer;

begin

begin

 for i:=1 to 50 do

   a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве

 writeln('Заполненный массив: ');

 for i:=1 to 50 do

   write(a[i],' '); end; // выводим массив на экран до проверки

writeln; //новая строка

writeln('Введите значение числа K: '); readln(k);

writeln('Элементы массива, кратные K:');

for i:=1 to 50 do

if (a[i] mod k = 0) then write(a[i],' ');  

end.

Объяснение:

i - порядковый номер элемента

a - сам массив

k - вводимое число

В остальном оставила комментарии.

Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.


ИНФОРМАТИКА 9 КЛАСС Работа с системой программирования на языке Паскаль Напишите программу для реа
bike-garage8
Я, правда, не знаю, как у вас на уроках изображают реле и контакторы, но схематически эту задачу можно представить так. На входы a-z подается управляющее напряжение контакторами, а на рабочие контакты - напряжение (5, или скорее всего 12 вольт). Если на управляющую обмотку поступает напряжение, контакты замкнуты, и рабочее напряжение подходит сквозь них, выдавая результат. Соединение (точка) обозначает логическую инструкцию or, два контактора рядом - конструкцию and, например k and l или m and n. Если на выходе левой части схемы будет напряжение, или на выходе правой части, то на выходе всей этой схемы будет результирующее напряжение. Понимаю, что описано сумбурно, если будут вопросы, стучитесь в личку, попробую объяснить
Заранее . требуется записать в виде релейно-контакторной схемы следующий оператор: x=((a or b) and (

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Устное или ребусное путешествие к одному из слов алгоритма, программы, вещателя, компилятора, переводчика
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mac4roc3781
Наталья Юрьевич1228
okasnab
marketing6
Кристина Валентиновна
Гарик383
tsatskina857
Наталья_Васищев
melissa-80
Kalmikova1666
annakuzina2023
layna1241383
airlineskozlova69
sergeystepanov231
bulin2001