qwert28027170
?>

найти ошибку в программе PascalABC.NET Далеко не все в Тентуре имеют право носить малиновые штаны, и конечно, не все владеют пепелацем с гравицапой, зато один предприимчивый чатланин поставил несколько ловушек, захватывающих отваливающиеся детали с пролетающих мимо инопланетных кораблей. Каждое утро он их обходит, в надежде, что рано или поздно из этих запчастей ему удастся собрать какое-нибудь транспортное средство. Путь свой чатланин планирует по карте, на которой аккуратно отмечены ловушки, отсчитывая начало координат от собственного дома. Начинается обход от дома, и в нем же и заканчивается. Требуется определить, какое расстояние проходит чатланин за день. В первой строке входного файла INPUT.TXT находится натуральное число N – количество ловушек, установленных чатланином (N ≤ 10), далее следуют N строк формата «X Y», описывающих координаты ловушек в порядке их обхода (-10 ≤ X, Y ≤ 10; X, Y – целые числа В выходной файл OUTPUT.TXT выведите общее расстояние, которое пройдет чатланин, обойдя все ловушки в приведенном порядке и вернувшись в начало координат от последней ловушки, с точностью до трех знаков после запятой. Вот сама программа: function len(x1, y1, x2, y2:integer):double; begin len:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)) end; var x1, y1, y2, x2, n, i:integer; l:real; begin x1:=0; y1:=0; read(n); for i:=1 to n do begin read(x2, y2); l:=len(x1, y1, x2, y2); x1:=x2; y1:=y2; l:=l+len(x2, y2, 0, 0); end; writeln(l:2:3); end.

Информатика

Ответы

kazanoop
Составим уравнение
87_{10}=ab2_n, \ a \in [1..n-1], \, b \in[0..n-1], \, a,b \in \mathbb N
Воспользуемся расширенной записью числа
87=an²+bn+2 → an²+bn-85=0
Известно, что если многочлен с целочисленными коэффициентами имеет хотя бы один вещественный корень, то он находится среди делителей свободного члена. Нас интересуют только натуральные делители, большие 2, поскольку n - основание системы счисления и в этой системе имеется цифра 2.
85 = 5 × 17. Число 17 не подходит, потому что 17>10 и двухзначное десятичное число в системе счисления с основанием, большим 10, не может иметь в записи больше двух знаков. Следовательно, n=5.

Для проверки переводим 87 в систему счисления по основанию 5.
87 / 5 = 17, остаток 2
17 / 5 = 3, остаток 2
3 / 5 = 0, остаток 3.
Выписываем остатки в обратном порядке: 322
87₁₀ = 322₅ - в числе три разряда и оно оканчивается двойкой.

ответ: N=5
bessalaias
Составим уравнение
87_{10}=ab2_n, \ a \in [1..n-1], \, b \in[0..n-1], \, a,b \in \mathbb N
Воспользуемся расширенной записью числа
87=an²+bn+2 → an²+bn-85=0
Известно, что если многочлен с целочисленными коэффициентами имеет хотя бы один вещественный корень, то он находится среди делителей свободного члена. Нас интересуют только натуральные делители, большие 2, поскольку n - основание системы счисления и в этой системе имеется цифра 2.
85 = 5 × 17. Число 17 не подходит, потому что 17>10 и двухзначное десятичное число в системе счисления с основанием, большим 10, не может иметь в записи больше двух знаков. Следовательно, n=5.

Для проверки переводим 87 в систему счисления по основанию 5.
87 / 5 = 17, остаток 2
17 / 5 = 3, остаток 2
3 / 5 = 0, остаток 3.
Выписываем остатки в обратном порядке: 322
87₁₀ = 322₅ - в числе три разряда и оно оканчивается двойкой.

ответ: N=5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

найти ошибку в программе PascalABC.NET Далеко не все в Тентуре имеют право носить малиновые штаны, и конечно, не все владеют пепелацем с гравицапой, зато один предприимчивый чатланин поставил несколько ловушек, захватывающих отваливающиеся детали с пролетающих мимо инопланетных кораблей. Каждое утро он их обходит, в надежде, что рано или поздно из этих запчастей ему удастся собрать какое-нибудь транспортное средство. Путь свой чатланин планирует по карте, на которой аккуратно отмечены ловушки, отсчитывая начало координат от собственного дома. Начинается обход от дома, и в нем же и заканчивается. Требуется определить, какое расстояние проходит чатланин за день. В первой строке входного файла INPUT.TXT находится натуральное число N – количество ловушек, установленных чатланином (N ≤ 10), далее следуют N строк формата «X Y», описывающих координаты ловушек в порядке их обхода (-10 ≤ X, Y ≤ 10; X, Y – целые числа В выходной файл OUTPUT.TXT выведите общее расстояние, которое пройдет чатланин, обойдя все ловушки в приведенном порядке и вернувшись в начало координат от последней ловушки, с точностью до трех знаков после запятой. Вот сама программа: function len(x1, y1, x2, y2:integer):double; begin len:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)) end; var x1, y1, y2, x2, n, i:integer; l:real; begin x1:=0; y1:=0; read(n); for i:=1 to n do begin read(x2, y2); l:=len(x1, y1, x2, y2); x1:=x2; y1:=y2; l:=l+len(x2, y2, 0, 0); end; writeln(l:2:3); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

katyn76
Irinagarmonshikova
shutovaa3471
marinazubcko16729
mitin228133770
Fetyukov
mishapavlov9
mariyachervonnaya44
spec-nt
alexk13
Guru-tailor
info664
BogdanR106203
avto3132
Dmitrychekov9